|
@@ -0,0 +1,77 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2007-2011 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=apr-util
|
|
11
|
+PKG_VERSION:=1.5.3
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
15
|
+PKG_SOURCE_URL:=http://mirrors.ibiblio.org/apache/apr/
|
|
16
|
+PKG_MD5SUM:=6f3417691c7a27090f36e7cf4d94b36e
|
|
17
|
+PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
|
|
18
|
+PKG_LICENSE:=Apache License
|
|
19
|
+
|
|
20
|
+PKG_FIXUP:=autoreconf
|
|
21
|
+PKG_REMOVE_FILES:=aclocal.m4 build/ltmain.sh
|
|
22
|
+
|
|
23
|
+PKG_INSTALL:=1
|
|
24
|
+
|
|
25
|
+include $(INCLUDE_DIR)/package.mk
|
|
26
|
+include $(INCLUDE_DIR)/nls.mk
|
|
27
|
+
|
|
28
|
+define Package/libaprutil
|
|
29
|
+ SECTION:=libs
|
|
30
|
+ CATEGORY:=Libraries
|
|
31
|
+ DEPENDS:=+libapr +libexpat +libsqlite3 +libuuid $(ICONV_DEPENDS)
|
|
32
|
+ TITLE:=Apache Portable Runtime Utility Library
|
|
33
|
+ URL:=http://apr.apache.org/
|
|
34
|
+endef
|
|
35
|
+
|
|
36
|
+TARGET_CFLAGS += $(FPIC)
|
|
37
|
+TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
|
|
38
|
+
|
|
39
|
+CONFIGURE_ARGS += \
|
|
40
|
+ --with-pgsql=no \
|
|
41
|
+ --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
|
|
42
|
+ --with-expat="$(STAGING_DIR)/usr" \
|
|
43
|
+ --without-sqlite2 \
|
|
44
|
+ --with-sqlite3="$(STAGING_DIR)/usr" \
|
|
45
|
+ --with-iconv="$(ICONV_PREFIX)" \
|
|
46
|
+
|
|
47
|
+CONFIGURE_VARS += \
|
|
48
|
+ ac_cv_file_dbd_apr_dbd_mysql_c=no \
|
|
49
|
+ ac_cv_path_ODBC_CONFIG= \
|
|
50
|
+ APR_BUILD_DIR="$(STAGING_DIR)/usr/share/build-1" \
|
|
51
|
+
|
|
52
|
+MAKE_FLAGS += \
|
|
53
|
+ APRUTIL_LIBS="-lsqlite3 $(TARGET_LDFLAGS) -lexpat $(if $(ICONV_FULL),-liconv) -lapr-1 -luuid -lm -lcrypt" \
|
|
54
|
+
|
|
55
|
+define Build/InstallDev
|
|
56
|
+ $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include/apr-1/ $(1)/usr/lib $(1)/usr/lib/pkgconfig/
|
|
57
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/apu-1-config \
|
|
58
|
+ $(1)/usr/bin/
|
|
59
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/apr-1/* \
|
|
60
|
+ $(1)/usr/include/apr-1/
|
|
61
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libaprutil-1.{la,a,so*} \
|
|
62
|
+ $(1)/usr/lib/
|
|
63
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/apr-util-1.pc \
|
|
64
|
+ $(1)/usr/lib/pkgconfig/
|
|
65
|
+ $(SED) 's, -e \"s -I$$$$prefix/lib g\",,g' $(1)/usr/bin/apu-1-config
|
|
66
|
+ $(SED) 's,^libdir=\"$$$${exec_prefix}/lib,libdir=\"$(STAGING_DIR)/usr/lib,g' $(1)/usr/bin/apu-1-config
|
|
67
|
+ $(SED) 's,^includedir=\"$$$${prefix}/include/,includedir=\"$(STAGING_DIR)/usr/include/,g' $(1)/usr/bin/apu-1-config
|
|
68
|
+ $(SED) 's,-L$$$$libdir,,g' $(1)/usr/bin/apu-1-config
|
|
69
|
+ $(SED) 's,-R$$$$libdir,,g' $(1)/usr/bin/apu-1-config
|
|
70
|
+endef
|
|
71
|
+
|
|
72
|
+define Package/libaprutil/install
|
|
73
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
74
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libaprutil-1.so.* $(1)/usr/lib/
|
|
75
|
+endef
|
|
76
|
+
|
|
77
|
+$(eval $(call BuildPackage,libaprutil))
|