Bladeren bron

rtorrent: update to 0.9.6, disable ipv6

Update rtorrent to 0.9.6.
Update patches.
Disable ipv6 in rtorrent, as ipv6 is disabled also in libtorrent.

Libtorrent compilation has been broken since #1181 got merged
and ipv6 got enabled. Users have seen issues like #1316 and #1804

IPv6 support in libtorrent & rtorrent master is not complete.
Instead there is a separate ipv6 branch, which still needs some
cleanup before mainstream use. See discussion at
https://github.com/rakshasa/rtorrent/issues/59#issuecomment-56651538
So, it makes no sense to use ipv6 with the master branch.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Hannu Nyman 9 jaren geleden
bovenliggende
commit
b28a6201cf
2 gewijzigde bestanden met toevoegingen van 5 en 5 verwijderingen
  1. 4
    4
      net/rtorrent/Makefile
  2. 1
    1
      net/rtorrent/patches/100-fix-cross_compile.patch

+ 4
- 4
net/rtorrent/Makefile Bestand weergeven

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2007-2013 OpenWrt.org
2
+# Copyright (C) 2007-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,13 +8,13 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=rtorrent
11
-PKG_VERSION:=0.9.4-git-1
11
+PKG_VERSION:=0.9.6-git-1
12 12
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
13 13
 
14 14
 PKG_SOURCE_PROTO:=git
15 15
 PKG_SOURCE_URL:=https://github.com/rakshasa/rtorrent.git
16 16
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
17
-PKG_SOURCE_VERSION:=7343e33a6a0d279179b304a380bf011f1c8be64a
17
+PKG_SOURCE_VERSION:=62cb5a4605c0664bc522e0e0da9c72f09cf643a9
18 18
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
19 19
 
20 20
 PKG_LICENSE:=GPL-2.0
@@ -73,7 +73,7 @@ CONFIGURE_ARGS+= \
73 73
 	--enable-shared \
74 74
 	--disable-static \
75 75
 	--disable-debug \
76
-	$(call autoconf_bool,CONFIG_IPV6,ipv6)
76
+	--disable-ipv6
77 77
 
78 78
 ifeq ($(BUILD_VARIANT),rpc)
79 79
 	CONFIGURE_ARGS += \

+ 1
- 1
net/rtorrent/patches/100-fix-cross_compile.patch Bestand weergeven

@@ -1,6 +1,6 @@
1 1
 --- a/configure.ac
2 2
 +++ b/configure.ac
3
-@@ -4,7 +4,6 @@ AC_DEFINE(API_VERSION, 8, api version)
3
+@@ -4,7 +4,6 @@ AC_DEFINE(API_VERSION, 9, api version)
4 4
  
5 5
  AM_INIT_AUTOMAKE
6 6
  AC_CONFIG_HEADERS(config.h)