|
@@ -0,0 +1,67 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2006-2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=jamvm
|
|
11
|
+PKG_VERSION:=2.0.0
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+PKG_LICENSE:=GPL-2.0+
|
|
14
|
+PKG_MAINTAINER:=Dana H. Myers <k6jq@comcast.net>
|
|
15
|
+
|
|
16
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
17
|
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
|
18
|
+PKG_MD5SUM:=a6e3321ef4b3cfb4afc20bd75452e11e
|
|
19
|
+
|
|
20
|
+PKG_USE_MIPS16:=0
|
|
21
|
+
|
|
22
|
+PKG_FIXUP:=autoreconf
|
|
23
|
+PKG_INSTALL:=1
|
|
24
|
+
|
|
25
|
+include $(INCLUDE_DIR)/package.mk
|
|
26
|
+
|
|
27
|
+define Package/jamvm
|
|
28
|
+ SUBMENU:=Java
|
|
29
|
+ SECTION:=lang
|
|
30
|
+ CATEGORY:=Languages
|
|
31
|
+ TITLE:=A compact Java Virtual Machine
|
|
32
|
+ URL:=http://sourceforge.net/projects/jamvm
|
|
33
|
+ DEPENDS:=+zlib +libpthread +librt +classpath @!avr32
|
|
34
|
+endef
|
|
35
|
+
|
|
36
|
+define Package/jamvm/description
|
|
37
|
+ JamVM is a new Java Virtual Machine which conforms to the JVM
|
|
38
|
+ specification version (blue book). In comparison to most other VM's (free
|
|
39
|
+ and commercial) it is extremely small.However, unlike other small VMs
|
|
40
|
+ (e.g. KVM) it is designed to support the full specification, and includes
|
|
41
|
+ support for object finalisation, Soft/Weak/Phantom References, the Java
|
|
42
|
+ Native Interface (JNI) and the Reflection API.
|
|
43
|
+endef
|
|
44
|
+
|
|
45
|
+CONFIGURE_ARGS += \
|
|
46
|
+ --with-java-runtime-library=gnuclasspath \
|
|
47
|
+ --with-classpath-install-dir=/usr \
|
|
48
|
+ --disable-int-inlining \
|
|
49
|
+ --disable-shared \
|
|
50
|
+ --without-pic
|
|
51
|
+
|
|
52
|
+MAKE_FLAGS += \
|
|
53
|
+ GLIBJ_ZIP=$(STAGING_DIR)/usr/share/classpath/glibj.zip
|
|
54
|
+
|
|
55
|
+define Package/jamvm/install
|
|
56
|
+ $(INSTALL_DIR) $(1)/usr
|
|
57
|
+ $(CP) \
|
|
58
|
+ $(PKG_INSTALL_DIR)/usr/bin \
|
|
59
|
+ $(PKG_INSTALL_DIR)/usr/share \
|
|
60
|
+ $(1)/usr/
|
|
61
|
+endef
|
|
62
|
+
|
|
63
|
+define Build/InstallDev
|
|
64
|
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
|
|
65
|
+endef
|
|
66
|
+
|
|
67
|
+$(eval $(call BuildPackage,jamvm))
|