Browse Source

knxd: bump to latest release, add conffile

Signed-off-by: Othmar Truniger <github@truniger.ch>
Othmar Truniger 10 years ago
parent
commit
b446dbba58
1 changed files with 12 additions and 13 deletions
  1. 12
    13
      net/knxd/Makefile

+ 12
- 13
net/knxd/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2008-2014 OpenWrt.org
2
+# Copyright (C) 2008-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -7,14 +7,12 @@
7 7
 
8 8
 ### Remarks
9 9
 ### 'python pascal ruby lua' need to be deleted in src/clients/Makefile.am
10
-### USB stays disabled as long as official libusb-1.0 remains on version 1.0.9
11
-### you need to build libusb-1.0 >= 1.0.10 yourself if you want to add USB support
12 10
 
13 11
 include $(TOPDIR)/rules.mk
14 12
 
15 13
 PKG_NAME:=knxd
16
-PKG_REV:=b01d99c6748cc565f1be69b68cf2b9d3115e8ce5
17
-PKG_VERSION:=2014-12-20
14
+PKG_REV:=c97a543043297e38bbe04e1030916e8a4737373c
15
+PKG_VERSION:=2015-01-14
18 16
 PKG_RELEASE:=1
19 17
 
20 18
 PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
@@ -41,7 +39,7 @@ define Package/knxd
41 39
   CATEGORY:=Network
42 40
   TITLE:=Eib KNX deamon
43 41
   URL:=https://github.com/Makki1/knxd
44
-  DEPENDS:=pthsem
42
+  DEPENDS:=pthsem libusb-1.0
45 43
 endef
46 44
 # use this if you want to support USB
47 45
 # DEPENDS:=pthsem libusb-1.0
@@ -55,10 +53,8 @@ define Package/knxd-tools
55 53
   CATEGORY:=Network
56 54
   TITLE:=Eib KNX Utils
57 55
   URL:=https://github.com/Makki1/knxd
58
-  DEPENDS:=pthsem
56
+  DEPENDS:=pthsem libusb-1.0
59 57
 endef
60
-# use this if you want to support USB
61
-# DEPENDS:=pthsem libusb-1.0
62 58
 
63 59
 define Package/knxd-tools/description
64 60
 EIB KNX Tools
@@ -74,7 +70,7 @@ define Build/Configure
74 70
 		--enable-eibnetip \
75 71
 		--enable-eibnetiptunnel \
76 72
 		--enable-eibnetipserver \
77
-		--disable-usb \
73
+		--enable-usb \
78 74
 		--enable-tpuart \
79 75
 		--enable-tpuarts \
80 76
 		--disable-pei16 \
@@ -87,10 +83,14 @@ endef
87 83
 define Build/Compile
88 84
 	$(MAKE) -C $(PKG_BUILD_DIR) \
89 85
 		CC=$(TARGET_CC) \
90
-		LIBS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib -fno-builtin -nostdinc++ -nodefaultlibs -lc -lm -lgcc -largp -lpthsem" \
86
+		LIBS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib -fno-builtin -nodefaultlibs -lc -lm -lgcc -largp -lpthsem" \
91 87
 		CPPFLAGS="-I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include"
92 88
 endef
93 89
 
90
+define Package/knxd/conffiles
91
+  /etc/config/knxd
92
+endef
93
+
94 94
 define Package/knxd/install
95 95
 	$(INSTALL_DIR) $(1)/usr/bin
96 96
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/server/knxd $(1)/usr/bin/
@@ -98,13 +98,12 @@ define Package/knxd/install
98 98
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/tools/bcu/bcuread $(1)/usr/bin/
99 99
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/tools/eibnet/eibnetsearch $(1)/usr/bin/
100 100
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/tools/eibnet/eibnetdescribe $(1)/usr/bin/
101
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/tools/eibnet/findknxusb $(1)/usr/bin/
101 102
 	$(INSTALL_DIR) $(1)/etc/init.d
102 103
 	$(INSTALL_BIN) ./files/knxd.init $(1)/etc/init.d/knxd
103 104
 	$(INSTALL_DIR) $(1)/etc/config
104 105
 	$(INSTALL_DATA) ./files/knxd.config $(1)/etc/config/knxd
105 106
 endef
106
-#       add this line above to support USB
107
-#       $(CP) $(PKG_BUILD_DIR)/src/usb/findknxusb $(1)/usr/bin/
108 107
 
109 108
 define Package/knxd-tools/install
110 109
 	$(INSTALL_DIR) $(1)/usr/lib