Browse Source

openCV: Add library openCV2.4.10

[Etienne CHAMPETIER: compile tested for ar71xx]
Signed-off-by: Etienne CHAMPETIER <champetier.etienne@gmail.com>
Signed-off-by: Jialei Hao <schumy@wrtnode.com>
Jialei Hao 10 years ago
parent
commit
b4e860f622
2 changed files with 87 additions and 0 deletions
  1. 64
    0
      libs/opencv/Makefile
  2. 23
    0
      libs/opencv/README.md

+ 64
- 0
libs/opencv/Makefile View File

@@ -0,0 +1,64 @@
1
+#
2
+# Copyright (C) 2013-2014 wrtnode.com
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=opencv
11
+PKG_VERSION:=2.4.10
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
15
+PKG_SOURCE_URL:=http://sourceforge.net/projects/opencvlibrary/files/opencv-unix/2.4.10/
16
+PKG_MD5SUM:=ec63952d3a3dff965d5fdde765926821
17
+
18
+PKG_LICENSE:=BSD-3-Clause
19
+PKG_LICENSE_FILES:=LICENSE
20
+
21
+include $(INCLUDE_DIR)/package.mk
22
+include $(INCLUDE_DIR)/cmake.mk
23
+
24
+
25
+define Package/opencv/Default/description
26
+ OpenCV (Open Source Computer Vision Library) is an open source computer
27
+ vision and machine learning software library. OpenCV was built to provide
28
+ a common infrastructure for computer vision applications and to accelerate
29
+ the use of machine perception in the commercial products. Being a
30
+ BSD-licensed product, OpenCV makes it easy for businesses to utilize
31
+ and modify the code.
32
+endef
33
+
34
+define Package/opencv
35
+  SECTION:=libs
36
+  CATEGORY:=Libraries
37
+  TITLE:=opencv-2.4.10
38
+  URL:=http://opencv.org/
39
+  MAINTAINER:=WRTnode Team <pub@wrtnode.com>
40
+  DEPENDS:=+libpthread +librt +libstdcpp +zlib +libjpeg
41
+endef
42
+
43
+
44
+PKG_INSTALL:=1
45
+
46
+CMAKE_OPTIONS += -DBUILD_opencv_gpu:BOOL=OFF \
47
+	 -DWITH_1394:BOOL=OFF -DBUILD_opencv_stitching:BOOL=OFF \
48
+	 -DBUILD_opencv_superres:BOOL=OFF -DBUILD_opencv_ts:BOOL=OFF
49
+
50
+define Build/InstallDev
51
+	$(INSTALL_DIR) $(1)/usr/include
52
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/opencv $(1)/usr/include/
53
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/opencv2 $(1)/usr/include/
54
+	$(INSTALL_DIR) $(1)/usr/lib
55
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libopencv* $(1)/usr/lib/
56
+endef
57
+
58
+define Package/opencv/install
59
+	$(INSTALL_DIR) $(1)/usr/lib
60
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libopencv* $(1)/usr/lib/
61
+
62
+endef
63
+
64
+$(eval $(call BuildPackage,opencv))

+ 23
- 0
libs/opencv/README.md View File

@@ -0,0 +1,23 @@
1
+Introduction
2
+===
3
+
4
+#### OpenCV: Open Source Computer Vision Library.OpenCV is based on (open source) issued cross-platform computer vision library, you can run on Linux, Windows and Mac OS operating systems.
5
+
6
+#### Resources
7
+
8
+* Homepage: <http://opencv.org>
9
+* Docs: <http://docs.opencv.org>
10
+* Q&A forum: <http://answers.opencv.org>
11
+* Issue tracking: <http://code.opencv.org>
12
+
13
+#### Contributing
14
+
15
+Please read before starting work on a pull request: <http://code.opencv.org/projects/opencv/wiki/How_to_contribute>
16
+
17
+Summary of guidelines:
18
+
19
+* One pull request per issue;
20
+* Choose the right base branch;
21
+* Include tests and documentation;
22
+* Clean up "oops" commits before submitting;
23
+* Follow the coding style guide.