瀏覽代碼

python-enum34: new package

From the README:

enum34 is the new Python stdlib enum module available in Python 3.4
backported for previous versions of Python from 2.4 to 3.3.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Jeffery To 9 年之前
父節點
當前提交
b6aa1232b0
共有 1 個檔案被更改,包括 44 行新增0 行删除
  1. 44
    0
      lang/python-enum34/Makefile

+ 44
- 0
lang/python-enum34/Makefile 查看文件

@@ -0,0 +1,44 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=enum34
11
+PKG_VERSION:=1.0.4
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/e/enum34
16
+PKG_MD5SUM:=ac80f432ac9373e7d162834b264034b6
17
+
18
+PKG_LICENSE:=BSD-3-Clause
19
+PKG_LICENSE_FILES:=enum/LICENSE
20
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
21
+
22
+include $(INCLUDE_DIR)/package.mk
23
+$(call include_mk, python-package.mk)
24
+
25
+define Package/python-enum34
26
+	SECTION:=lang
27
+	CATEGORY:=Languages
28
+	SUBMENU:=Python
29
+	TITLE:=python-enum34
30
+	URL:=https://pypi.python.org/pypi/enum34/
31
+	DEPENDS:=+python-light
32
+endef
33
+
34
+define Package/python-enum34/description
35
+enum34 is the new Python stdlib enum module available in Python 3.4
36
+backported for previous versions of Python from 2.4 to 3.3.
37
+endef
38
+
39
+define Build/Compile
40
+	$(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
41
+endef
42
+
43
+$(eval $(call PyPackage,python-enum34))
44
+$(eval $(call BuildPackage,python-enum34))