Browse Source

Merge pull request #711 from tru7/libs-pthsem

pthsem: new package
Steven Barth 10 years ago
parent
commit
b764d7c85a
2 changed files with 80 additions and 0 deletions
  1. 68
    0
      libs/pthsem/Makefile
  2. 12
    0
      libs/pthsem/patches/001-linux3x-fix.patch

+ 68
- 0
libs/pthsem/Makefile View File

@@ -0,0 +1,68 @@
1
+#
2
+# Copyright (C) 2008-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=pthsem
11
+PKG_VERSION:=2.0.8
12
+PKG_RELEASE:=2
13
+
14
+PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
15
+PKG_LICENSE:=LGPL-2.1+
16
+PKG_LICENSE_FILES:=COPYING
17
+
18
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
19
+PKG_SOURCE_URL:=http://www.auto.tuwien.ac.at/~mkoegler/pth/
20
+PKG_MD5SUM:=9144b26dcc27e67498d63dd5456f934c
21
+
22
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
23
+PKG_FIXUP:=autoreconf
24
+PKG_BUILD_PARALLEL:=1
25
+PKG_INSTALL:=1
26
+
27
+include $(INCLUDE_DIR)/package.mk
28
+
29
+define Package/pthsem
30
+  SECTION:=libs
31
+  CATEGORY:=Libraries
32
+  TITLE:=GNU pth extended with semaphore support
33
+  URL:=http://www.auto.tuwien.ac.at/~mkoegler/index.php/pth
34
+endef
35
+
36
+define Package/pthsem/description
37
+  GNU pth is a user mode multi threading library.
38
+  pthsem is an extend version, with support for semaphores added. It can be installed parallel to a normal pth.
39
+endef
40
+
41
+MAKE_FLAGS += \
42
+        OPTIM="$(TARGET_CFLAGS)" \
43
+        CFLAGS="$(TARGET_CFLAGS)" \
44
+        DESTDIR="$(PKG_INSTALL_DIR)"
45
+
46
+define Build/InstallDev
47
+        $(INSTALL_DIR) $(2)/bin
48
+        $(INSTALL_BIN) \
49
+                $(PKG_INSTALL_DIR)/usr/bin/pthsem-config \
50
+                $(2)/bin/
51
+        $(SED) \
52
+                's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
53
+                $(2)/bin/pthsem-config
54
+
55
+        $(INSTALL_DIR) $(1)/usr/include
56
+        $(CP)   $(PKG_INSTALL_DIR)/usr/include/*.h \
57
+                $(1)/usr/include/
58
+        $(INSTALL_DIR) $(1)/usr/lib
59
+        $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libpthsem.{a,la,so*} \
60
+                $(1)/usr/lib/
61
+endef
62
+
63
+define Package/pthsem/install
64
+        $(INSTALL_DIR) $(1)/usr/lib
65
+        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpthsem.so.* $(1)/usr/lib/
66
+endef
67
+
68
+$(eval $(call BuildPackage,pthsem))

+ 12
- 0
libs/pthsem/patches/001-linux3x-fix.patch View File

@@ -0,0 +1,12 @@
1
+--- pthsem-2.0.8/acinclude.m4
2
++++ pthsem-2.0.8/acinclude.m4
3
+@@ -892,6 +892,8 @@
4
+         case "x`uname -r`" in
5
+ changequote(, )dnl
6
+             x2.[23456789]* ) ;;
7
++changequote(, )dnl
8
++            x3.* ) ;;
9
+ changequote([, ])
10
+             * ) braindead=yes ;;
11
+         esac
12
+