Browse Source

ocserv: update to 0.9.0

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Nikos Mavrogiannopoulos 10 years ago
parent
commit
b83057ce9c

+ 3
- 3
net/ocserv/Makefile View File

@@ -8,13 +8,13 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=ocserv
11
-PKG_VERSION:=0.8.9
12
-PKG_RELEASE:=4
11
+PKG_VERSION:=0.9.0
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_BUILD_DIR :=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
16 16
 PKG_SOURCE_URL :=ftp://ftp.infradead.org/pub/ocserv/
17
-PKG_MD5SUM:=cd935cc89bffac75c825e66ef71f6a73
17
+PKG_MD5SUM:=50994bf7e40fd6bedda33bb2f99b1f11
18 18
 
19 19
 PKG_LICENSE:=GPLv2
20 20
 PKG_LICENSE_FILES:=COPYING

+ 1
- 0
net/ocserv/README View File

@@ -15,6 +15,7 @@ config ocserv 'config'
15 15
 	option auth 'plain'
16 16
 	option zone 'vpn'
17 17
 	option default_domain 'lan'
18
+	option compression '1'
18 19
 	option enable '1'
19 20
 
20 21
 config dns

+ 11
- 2
net/ocserv/files/ocserv.conf.template View File

@@ -43,6 +43,12 @@ max-same-clients = |MAX_SAME|
43 43
 tcp-port = |PORT|
44 44
 |UDP|udp-port = |PORT|
45 45
 
46
+# Stats report time. The number of seconds after which each
47
+# worker process will report its usage statistics (number of
48
+# bytes transferred etc). This is useful when accounting like
49
+# radius is in use.
50
+#stats-report-time = 360
51
+
46 52
 # Keepalive in seconds
47 53
 keepalive = 32400
48 54
 
@@ -109,11 +115,14 @@ server-key = /etc/ocserv/server-key.pem
109 115
 # The revocation list of the certificates issued by the 'ca-cert' above.
110 116
 #crl = /etc/ocserv/crl.pem
111 117
 
118
+# Uncomment this to enable compression negotiation (LZS, LZ4).
119
+|COMPRESSION|compression = true
120
+
112 121
 # GnuTLS priority string
113
-tls-priorities = "NORMAL:%SERVER_PRECEDENCE:%COMPAT"
122
+tls-priorities = "NORMAL:%SERVER_PRECEDENCE:%COMPAT:-VERS-SSL3.0"
114 123
 
115 124
 # To enforce perfect forward secrecy (PFS) on the main channel.
116
-#tls-priorities = "NORMAL:%SERVER_PRECEDENCE:%COMPAT:-RSA"
125
+#tls-priorities = "NORMAL:%SERVER_PRECEDENCE:%COMPAT:-VERS-SSL3.0:-RSA"
117 126
 
118 127
 # The time (in seconds) that a client is allowed to stay connected prior
119 128
 # to authentication

+ 4
- 0
net/ocserv/files/ocserv.init View File

@@ -10,6 +10,7 @@ setup_config() {
10 10
 	config_get max_same     $1 max_same "2"
11 11
 	config_get dpd          $1 dpd "120"
12 12
 	config_get predictable_ips  $1 predictable_ips "1"
13
+	config_get compression  $1 compression "0"
13 14
 	config_get udp          $1 udp "1"
14 15
 	config_get auth         $1 auth "plain"
15 16
 	config_get cisco_compat $1 cisco_compat "1"
@@ -20,11 +21,13 @@ setup_config() {
20 21
 
21 22
 	enable_default_domain="#"
22 23
 	enable_udp="#"
24
+	enable_compression="#"
23 25
 	test $predictable_ips = "0" && predictable_ips="false"
24 26
 	test $predictable_ips = "1" && predictable_ips="true"
25 27
 	test $cisco_compat = "0" && cisco_compat="false"
26 28
 	test $cisco_compat = "1" && cisco_compat="true"
27 29
 	test $udp = "1" && enable_udp=""
30
+	test $compression = "1" && enable_compression=""
28 31
 	test -z $default_domain && enable_default_domain=""
29 32
 	test -z $ip6addr && enable_ipv6="#"
30 33
 
@@ -49,6 +52,7 @@ setup_config() {
49 52
 	    -e "s/|ENABLE_DEFAULT_DOMAIN|/$enable_default_domain/g" \
50 53
 	    -e "s/|CISCO_COMPAT|/$cisco_compat/g" \
51 54
 	    -e "s/|UDP|/$enable_udp/g" \
55
+	    -e "s/|COMPRESSION|/$enable_compression/g" \
52 56
 	    -e "s/|IPV4ADDR|/$ipaddr/g" \
53 57
 	    -e "s/|NETMASK|/$netmask/g" \
54 58
 	    -e "s/|IPV6ADDR|/$ipv6_addr/g" \

+ 0
- 12
net/ocserv/patches/001-ocpasswd-sha2crypt.patch View File

@@ -1,12 +0,0 @@
1
-diff -ur ocserv-0.8.9/src/ocpasswd.c ocserv-0.8.9.new/src/ocpasswd.c
2
---- ocserv-0.8.9/src/ocpasswd.c	2014-11-29 19:49:38.000000000 +0100
3
-+++ ocserv-0.8.9.new/src/ocpasswd.c	2015-01-19 23:21:14.959144113 +0100
4
-@@ -69,7 +69,7 @@
5
- 		exit(1);
6
- 	}
7
- 
8
--	strcpy(salt, "$5$");
9
-+	strcpy(salt, "$1$");
10
- 	p = salt + 3;
11
- 
12
- 	for (i = 0; i < sizeof(_salt); i++) {