|
@@ -0,0 +1,43 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2008-2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=PyYAML
|
|
11
|
+PKG_VERSION:=3.11
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=http://pyyaml.org/download/pyyaml/
|
|
16
|
+PKG_MD5SUM:=f50e08ef0fe55178479d3a618efe21db
|
|
17
|
+
|
|
18
|
+PKG_LICENSE:=MIT
|
|
19
|
+PKG_LICENSE_FILES:=COPYING
|
|
20
|
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
|
|
21
|
+
|
|
22
|
+PKG_BUILD_DEPENDS:=python
|
|
23
|
+
|
|
24
|
+include $(INCLUDE_DIR)/package.mk
|
|
25
|
+$(call include_mk, python-package.mk)
|
|
26
|
+
|
|
27
|
+define Package/python-yaml
|
|
28
|
+ SUBMENU:=Python
|
|
29
|
+ SECTION:=lang
|
|
30
|
+ CATEGORY:=Languages
|
|
31
|
+ TITLE:=YAML parser and emitter for Python
|
|
32
|
+ URL:=http://pyyaml.org/wiki/PyYAML
|
|
33
|
+ DEPENDS:=+python +libyaml
|
|
34
|
+endef
|
|
35
|
+
|
|
36
|
+define Build/Compile
|
|
37
|
+ $(call Build/Compile/PyMod,,\
|
|
38
|
+ --with-libyaml install --prefix="$(PKG_INSTALL_DIR)/usr" \
|
|
39
|
+ )
|
|
40
|
+endef
|
|
41
|
+
|
|
42
|
+$(eval $(call PyPackage,python-yaml))
|
|
43
|
+$(eval $(call BuildPackage,python-yaml))
|