Переглянути джерело

mmc-utils: don't set -D_FORTIFY_SOURCE in Makefile

Now that security features are set globally, having the
FORTIFY_SOURCE option set in Makefile breaks the build when
CONFIG_PKG_FORTIFY_SOURCE_{1,2} is enabled as well.

arm-openwrt-linux-uclibcgnueabi-gcc  -Wall -Werror -Wuninitialized -Wundef -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2 -Os -pipe -march=armv6k -mtune=mpcore -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -mfloat-abi=soft -Wformat -Werror=format-security -fstack-protector -D_FORTIFY_SOURCE=1 -Wl,-z,now -Wl,-z,relro -Wp,-MMD,./.mmc.o.d,-MT,mmc.o -c mmc.c -o mmc.o
<command-line>:0:0: error: "_FORTIFY_SOURCE" redefined [-Werror]
<command-line>:0:0: note: this is the location of the previous definition
cc1: all warnings being treated as errors
Makefile:35: recipe for target 'mmc.o' failed

Fix this by removing -D_FORTIFY_SOURCE=2 from Makefile.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Daniel Golle 10 роки тому
джерело
коміт
ba4338d6f7

+ 1
- 1
utils/mmc-utils/Makefile Переглянути файл

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=mmc-utils
11 11
 PKG_VERSION=2015-03-06-$(PKG_SOURCE_VERSION)
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE_PROTO:=git
15 15
 PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git

+ 11
- 0
utils/mmc-utils/patches/001-dont-set-fortify-source-in-makefile.patch Переглянути файл

@@ -0,0 +1,11 @@
1
+Index: mmc-utils-f4eb241519f8d500ce6068a70d2389be39ac5189/Makefile
2
+===================================================================
3
+--- mmc-utils-f4eb241519f8d500ce6068a70d2389be39ac5189.orig/Makefile
4
++++ mmc-utils-f4eb241519f8d500ce6068a70d2389be39ac5189/Makefile
5
+@@ -1,5 +1,5 @@
6
+ CC ?= gcc
7
+-AM_CFLAGS = -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2
8
++AM_CFLAGS = -D_FILE_OFFSET_BITS=64
9
+ CFLAGS ?= -g -O2
10
+ objects = \
11
+ 	mmc.o \