|
@@ -0,0 +1,51 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2013-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+
|
|
7
|
+include $(TOPDIR)/rules.mk
|
|
8
|
+
|
|
9
|
+PKG_NAME:=dump1090
|
|
10
|
+PKG_VERSION:=2013-02-04
|
|
11
|
+PKG_RELEASE:=$(PKG_SOURCE_VERSION)
|
|
12
|
+
|
|
13
|
+PKG_SOURCE_PROTO:=git
|
|
14
|
+PKG_SOURCE_URL:=git://github.com/antirez/dump1090.git
|
|
15
|
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
16
|
+PKG_SOURCE_VERSION:=ff0fe38722c768c7269afa733790a2b968ea3099
|
|
17
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
18
|
+
|
|
19
|
+PKG_LICENSE:=BSD-3c
|
|
20
|
+
|
|
21
|
+PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
|
|
22
|
+
|
|
23
|
+include $(INCLUDE_DIR)/package.mk
|
|
24
|
+
|
|
25
|
+define Package/dump1090
|
|
26
|
+ SECTION:=utils
|
|
27
|
+ CATEGORY:=Utilities
|
|
28
|
+ TITLE:=Mode S decoder for the Realtek RTL2832U
|
|
29
|
+ URL:=https://github.com/antirez/dump1090
|
|
30
|
+ DEPENDS:=+libpthread +librtlsdr
|
|
31
|
+endef
|
|
32
|
+
|
|
33
|
+
|
|
34
|
+define Package/dump1090/description
|
|
35
|
+ Dump1090 is a Mode S decoder specifically designed for RTLSDR devices.
|
|
36
|
+ Embedded HTTP server that displays the currently detected aircrafts on
|
|
37
|
+ Google Maps. Network output in Basestation and AVR formats.
|
|
38
|
+endef
|
|
39
|
+
|
|
40
|
+MAKE_FLAGS += \
|
|
41
|
+ CFLAGS="$(TARGET_CFLAGS)"
|
|
42
|
+
|
|
43
|
+define Package/dump1090/install
|
|
44
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
45
|
+ $(CP) $(PKG_BUILD_DIR)/dump1090 $(1)/usr/bin
|
|
46
|
+
|
|
47
|
+ $(INSTALL_DIR) $(1)/usr/share/dump1090
|
|
48
|
+ $(CP) $(PKG_BUILD_DIR)/gmap.html $(1)/usr/share/dump1090
|
|
49
|
+endef
|
|
50
|
+
|
|
51
|
+$(eval $(call BuildPackage,dump1090))
|