|
@@ -1,5 +1,5 @@
|
1
|
1
|
#
|
2
|
|
-# Copyright (C) 2006-2015 OpenWrt.org
|
|
2
|
+# Copyright (C) 2006-2016 OpenWrt.org
|
3
|
3
|
#
|
4
|
4
|
# This is free software, licensed under the GNU General Public License v2.
|
5
|
5
|
# See /LICENSE for more information.
|
|
@@ -8,12 +8,12 @@
|
8
|
8
|
include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=privoxy
|
11
|
|
-PKG_VERSION:=3.0.23
|
12
|
|
-PKG_RELEASE:=4
|
|
11
|
+PKG_VERSION:=3.0.24
|
|
12
|
+PKG_RELEASE:=1
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=privoxy-$(PKG_VERSION)-stable-src.tar.gz
|
15
|
15
|
PKG_SOURCE_URL:=@SF/ijbswa
|
16
|
|
-PKG_MD5SUM:=bbe47d5ff1a54d9f9fc93a160532697f
|
|
16
|
+PKG_MD5SUM:=44a47d1a5000db8cccd61ace0e25e7f7
|
17
|
17
|
PKG_BUILD_DIR:=$(BUILD_DIR)/privoxy-$(PKG_VERSION)-stable
|
18
|
18
|
PKG_FIXUP:=autoreconf
|
19
|
19
|
PKG_INSTALL:=1
|
|
@@ -21,7 +21,31 @@ PKG_INSTALL:=1
|
21
|
21
|
PKG_LICENSE:=GPL-2.0
|
22
|
22
|
PKG_LICENSE_FILES:=LICENSE
|
23
|
23
|
|
24
|
|
-PKG_MAINTAINER:=christian.schoenebeck@gmail.com
|
|
24
|
+PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
|
|
25
|
+
|
|
26
|
+PKG_CONFIG_DEPENDS:= \
|
|
27
|
+ CONFIG_IPV6 \
|
|
28
|
+ \
|
|
29
|
+ CONFIG_PRIVOXY_disable-pthread \
|
|
30
|
+ CONFIG_PRIVOXY_disable-dynamic-pcre \
|
|
31
|
+ CONFIG_PRIVOXY_disable-zlib \
|
|
32
|
+ \
|
|
33
|
+ CONFIG_PRIVOXY_disable-toggle \
|
|
34
|
+ CONFIG_PRIVOXY_disable-force \
|
|
35
|
+ CONFIG_PRIVOXY_disable-fast-redirects \
|
|
36
|
+ CONFIG_PRIVOXY_disable-stats \
|
|
37
|
+ CONFIG_PRIVOXY_enable-ie-images \
|
|
38
|
+ CONFIG_PRIVOXY_disable-image-blocking \
|
|
39
|
+ CONFIG_PRIVOXY_disable-acl-support \
|
|
40
|
+ CONFIG_PRIVOXY_disable-trust-files \
|
|
41
|
+ CONFIG_PRIVOXY_disable-editor \
|
|
42
|
+ CONFIG_PRIVOXY_enable-no-gifs \
|
|
43
|
+ CONFIG_PRIVOXY_enable-graceful-termination \
|
|
44
|
+ CONFIG_PRIVOXY_enable-extended-host-patterns \
|
|
45
|
+ CONFIG_PRIVOXY_enable-external-filters \
|
|
46
|
+ CONFIG_PRIVOXY_enable-accept-filter \
|
|
47
|
+ CONFIG_PRIVOXY_enable-strptime-sanity-checks \
|
|
48
|
+ CONFIG_PRIVOXY_enable-compression
|
25
|
49
|
|
26
|
50
|
include $(INCLUDE_DIR)/package.mk
|
27
|
51
|
|
|
@@ -29,10 +53,11 @@ define Package/$(PKG_NAME)
|
29
|
53
|
SECTION:=net
|
30
|
54
|
CATEGORY:=Network
|
31
|
55
|
SUBMENU:=Web Servers/Proxies
|
32
|
|
- DEPENDS:=+libpcre +libpthread +zlib
|
33
|
56
|
TITLE:=Privoxy WEB Proxy
|
34
|
57
|
URL:=http://www.privoxy.org/
|
35
|
58
|
USERID:=privoxy=8118:privoxy=8118
|
|
59
|
+ MENU:=1
|
|
60
|
+ DEPENDS:=+!PRIVOXY_no_pcre:libpcre +!PRIVOXY_no_pthread:libpthread +!PRIVOXY_no_zlib:zlib
|
36
|
61
|
endef
|
37
|
62
|
|
38
|
63
|
# shown in LuCI package description
|
|
@@ -42,23 +67,45 @@ endef
|
42
|
67
|
|
43
|
68
|
# shown in make menuconfig <Help>
|
44
|
69
|
define Package/$(PKG_NAME)/config
|
45
|
|
-help
|
46
|
|
- Privoxy is a web proxy with advanced filtering capabilities for protecting
|
47
|
|
- privacy, modifying web page content, managing cookies, controlling access,
|
48
|
|
- and removing ads, banners, pop-ups and other obnoxious Internet junk.
|
49
|
|
- Privoxy has a very flexible configuration and can be customized to suit
|
50
|
|
- individual needs and tastes.
|
51
|
|
- Privoxy has application for both stand-alone systems and multi-user networks.
|
52
|
|
-
|
53
|
|
- Run as : $(USERID)
|
54
|
|
- Version: $(PKG_VERSION)-$(PKG_RELEASE)
|
55
|
|
- Home : $(URL)
|
56
|
|
-
|
57
|
|
- $(PKG_MAINTAINER)
|
|
70
|
+ help
|
|
71
|
+ Privoxy is a web proxy with advanced filtering capabilities for protecting
|
|
72
|
+ privacy, modifying web page content, managing cookies, controlling access,
|
|
73
|
+ and removing ads, banners, pop-ups and other obnoxious Internet junk.
|
|
74
|
+ Privoxy has a very flexible configuration and can be customized to suit
|
|
75
|
+ individual needs and tastes.
|
|
76
|
+ Privoxy has application for both stand-alone systems and multi-user networks.
|
|
77
|
+ Run as : $(USERID)
|
|
78
|
+ Version: $(PKG_VERSION)-$(PKG_RELEASE)
|
|
79
|
+ Home : $(URL)
|
|
80
|
+ $(PKG_MAINTAINER)
|
|
81
|
+
|
|
82
|
+ source "$(SOURCE)/Config.in"
|
58
|
83
|
endef
|
59
|
84
|
|
60
|
85
|
CONFIGURE_ARGS += \
|
61
|
|
- --sysconfdir=/etc/privoxy
|
|
86
|
+ --sysconfdir=/etc/privoxy \
|
|
87
|
+ $(if $(CONFIG_IPV6),,--disable-ipv6-support) \
|
|
88
|
+ \
|
|
89
|
+ $(if $(CONFIG_PRIVOXY_disable-pthread),--disable-pthread) \
|
|
90
|
+ $(if $(CONFIG_PRIVOXY_disable-dynamic-pcre),--disable-dynamic-pcre) \
|
|
91
|
+ $(if $(CONFIG_PRIVOXY_disable-zlib),--disable-zlib) \
|
|
92
|
+ \
|
|
93
|
+ $(if $(CONFIG_PRIVOXY_disable-toggle),--disable-toggle) \
|
|
94
|
+ $(if $(CONFIG_PRIVOXY_disable-force),--disable-force) \
|
|
95
|
+ $(if $(CONFIG_PRIVOXY_disable-fast-redirects),--disable-fast-redirects) \
|
|
96
|
+ $(if $(CONFIG_PRIVOXY_disable-stats),--disable-stats) \
|
|
97
|
+ $(if $(CONFIG_PRIVOXY_enable-ie-images),--enable-ie-images) \
|
|
98
|
+ $(if $(CONFIG_PRIVOXY_disable-image-blocking),--disable-image-blocking) \
|
|
99
|
+ $(if $(CONFIG_PRIVOXY_disable-acl-support),--disable-acl-support) \
|
|
100
|
+ $(if $(CONFIG_PRIVOXY_disable-trust-files),--disable-trust-files) \
|
|
101
|
+ $(if $(CONFIG_PRIVOXY_disable-editor),--disable-editor) \
|
|
102
|
+ $(if $(CONFIG_PRIVOXY_enable-no-gifs),--enable-no-gifs) \
|
|
103
|
+ $(if $(CONFIG_PRIVOXY_enable-graceful-termination),--enable-graceful-termination) \
|
|
104
|
+ $(if $(CONFIG_PRIVOXY_enable-extended-host-patterns),--enable-extended-host-patterns) \
|
|
105
|
+ $(if $(CONFIG_PRIVOXY_enable-external-filters),--enable-external-filters) \
|
|
106
|
+ $(if $(CONFIG_PRIVOXY_enable-accept-filter),--enable-accept-filter) \
|
|
107
|
+ $(if $(CONFIG_PRIVOXY_enable-strptime-sanity-checks),--enable-strptime-sanity-checks) \
|
|
108
|
+ $(if $(CONFIG_PRIVOXY_enable-compression),--enable-compression)
|
62
|
109
|
|
63
|
110
|
# needed otherwise errors during compile
|
64
|
111
|
MAKE_FLAGS:=
|
|
@@ -98,12 +145,20 @@ define Package/$(PKG_NAME)/install
|
98
|
145
|
-exec install -m0664 -t $(1)/etc/privoxy {} \;
|
99
|
146
|
|
100
|
147
|
$(INSTALL_DIR) \
|
|
148
|
+ $(1)/lib/upgrade/keep.d \
|
101
|
149
|
$(1)/etc/init.d \
|
102
|
150
|
$(1)/etc/hotplug.d/iface \
|
103
|
151
|
$(1)/etc/config
|
|
152
|
+ $(INSTALL_DATA) ./files/privoxy.upgrade $(1)/lib/upgrade/keep.d/privoxy
|
104
|
153
|
$(INSTALL_BIN) ./files/privoxy.init $(1)/etc/init.d/privoxy
|
105
|
154
|
$(INSTALL_BIN) ./files/privoxy.hotplug $(1)/etc/hotplug.d/iface/80-privoxy
|
106
|
155
|
$(INSTALL_CONF) ./files/privoxy.config $(1)/etc/config/privoxy
|
107
|
156
|
endef
|
108
|
157
|
|
|
158
|
+define Package/$(PKG_NAME)/postinst
|
|
159
|
+ #!/bin/sh
|
|
160
|
+ grep -i privoxy $${IPKG_INSTROOT}/etc/services >/dev/null 2>&1 || \
|
|
161
|
+ echo -e "privoxy\t8118" >> $${IPKG_INSTROOT}/etc/services
|
|
162
|
+endef
|
|
163
|
+
|
109
|
164
|
$(eval $(call BuildPackage,$(PKG_NAME)))
|