Преглед на файлове

libssh2: import from oldpackages, add myself as maintainer

Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
Jiri Slachta преди 10 години
родител
ревизия
bc4713cb7c
променени са 1 файла, в които са добавени 55 реда и са изтрити 0 реда
  1. 55
    0
      libs/libssh2/Makefile

+ 55
- 0
libs/libssh2/Makefile Целия файл

@@ -0,0 +1,55 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=libssh2
11
+PKG_VERSION:=1.4.3
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://www.libssh2.org/download
16
+PKG_MD5SUM:=071004c60c5d6f90354ad1b701013a0b
17
+
18
+PKG_INSTALL:=1
19
+
20
+include $(INCLUDE_DIR)/package.mk
21
+
22
+define Package/libssh2
23
+  SECTION:=libs
24
+  CATEGORY:=Libraries
25
+  TITLE:=SSH2 library
26
+  URL:=http://www.libssh2.org/
27
+  DEPENDS:=+libopenssl +zlib
28
+  MAINTAINER:=Jiri Slachta <slachta@cesnet.cz>
29
+endef
30
+
31
+define Package/libssh2/description
32
+ libssh2 is a client-side C library implementing the SSH2 protocol.
33
+endef
34
+
35
+TARGET_CFLAGS += $(FPIC)
36
+
37
+CONFIGURE_ARGS += \
38
+	--disable-examples-build \
39
+	--with-libssl-prefix=$(STAGING_DIR)/usr
40
+
41
+define Build/InstallDev
42
+	$(INSTALL_DIR) $(1)/usr/include
43
+	$(INSTALL_DIR) $(1)/usr/lib
44
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
45
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
46
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libssh2.so* $(1)/usr/lib/
47
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libssh2.pc $(1)/usr/lib/pkgconfig/
48
+endef
49
+
50
+define Package/libssh2/install
51
+	$(INSTALL_DIR) $(1)/usr/lib
52
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libssh2.so* $(1)/usr/lib/
53
+endef
54
+
55
+$(eval $(call BuildPackage,libssh2))