Bladeren bron

libnet-1.2.x: fix uClibc regression caused by #1410

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Jo-Philipp Wich 9 jaren geleden
bovenliggende
commit
bc4d049918
2 gewijzigde bestanden met toevoegingen van 9 en 4 verwijderingen
  1. 1
    1
      libs/libnet-1.2.x/Makefile
  2. 8
    3
      libs/libnet-1.2.x/patches/100-musl-compat.patch

+ 1
- 1
libs/libnet-1.2.x/Makefile Bestand weergeven

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=libnet
11 11
 PKG_VERSION:=1.2-rc3
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://sourceforge.net/projects/libnet-dev/files/

+ 8
- 3
libs/libnet-1.2.x/patches/100-musl-compat.patch Bestand weergeven

@@ -1,11 +1,16 @@
1 1
 --- a/src/libnet_link_linux.c
2 2
 +++ b/src/libnet_link_linux.c
3
-@@ -30,7 +30,7 @@
3
+@@ -30,13 +30,8 @@
4 4
  #include <sys/time.h>
5 5
  
6 6
  #include <net/if.h>
7 7
 -#if (__GLIBC__)
8
-+#if (!__UCLIBC__)
9 8
  #include <netinet/if_ether.h>
10 9
  #include <net/if_arp.h>
11
- #else
10
+-#else
11
+-#include <linux/if_arp.h>
12
+-#include <linux/if_ether.h>
13
+-#endif
14
+ 
15
+ #if (HAVE_PACKET_SOCKET)
16
+ #ifndef SOL_PACKET