Browse Source

iotivity: deactivate it on uClibc

IoTivity makes use of std::sto* and this is deactivated because GCC
things uClibc does not support C11, but it supports this part, not C11
completely. To make IoTivity work with uClibc a patch for this bug is
needed:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=58393

An option would be this patch:
https://github.com/maximeh/buildroot/blob/master/package/gcc/4.9.1/850-libstdcxx-uclibc-c99.patch

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Hauke Mehrtens 9 years ago
parent
commit
bc804531b8
1 changed files with 1 additions and 1 deletions
  1. 1
    1
      net/iotivity/Makefile

+ 1
- 1
net/iotivity/Makefile View File

@@ -33,7 +33,7 @@ include $(INCLUDE_DIR)/scons.mk
33 33
 define Package/iotivity
34 34
   SECTION:=net
35 35
   CATEGORY:=Network
36
-  DEPENDS:= +libpthread +librt +libstdcpp +libuuid
36
+  DEPENDS:=@!USE_UCLIBC +libpthread +librt +libstdcpp +libuuid
37 37
   TITLE:=IoTivity Library
38 38
   URL:=https://www.iotivity.org
39 39
 endef