Browse Source

lcdgrilo: add new package

Signed-off-by: W. Michael Petullo <mike@flyn.org>
W. Michael Petullo 9 years ago
parent
commit
be526f6f0e
2 changed files with 66 additions and 0 deletions
  1. 50
    0
      multimedia/lcdgrilo/Makefile
  2. 16
    0
      multimedia/lcdgrilo/files/lcdgrilo.init

+ 50
- 0
multimedia/lcdgrilo/Makefile View File

@@ -0,0 +1,50 @@
1
+#
2
+# Copyright (C) 2009-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=lcdgrilo
11
+PKG_VERSION:=0.0.7
12
+PKG_RELEASE:=1
13
+
14
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15
+
16
+PKG_LICENSE:=GPL-2.0
17
+PKG_LICENSE_FILES:=COPYING
18
+
19
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
20
+PKG_SOURCE_URL:=http://www.flyn.org/projects/lcdgrilo
21
+PKG_MD5SUM:=80a946bf144da5cc32bdf9f1aa2f91e6
22
+PKG_BUILD_DEPENDS:=+vala
23
+
24
+PKG_INSTALL:=1
25
+
26
+include $(INCLUDE_DIR)/package.mk
27
+include $(INCLUDE_DIR)/nls.mk
28
+
29
+define Package/lcdgrilo
30
+  SECTION:=multimedia
31
+  CATEGORY:=Multimedia
32
+  DEPENDS:=+grilo +grilo-plugins +libgee +libgstreamer1
33
+  TITLE:=lcdgrilo
34
+  URL:=http://www.flyn.org/projects/lcdgrilo/
35
+endef
36
+
37
+define Package/lcdgrilo/decription
38
+	A simple Grilo-based audio player meant to run on a Raspberry Pi with a PiFace CAD
39
+endef
40
+
41
+define Package/lcdgrilo/install
42
+	$(INSTALL_DIR) $(1)/usr/bin
43
+	$(INSTALL_DIR) $(1)/etc/init.d
44
+	$(CP) \
45
+		$(PKG_INSTALL_DIR)/usr/bin/lcdgrilo \
46
+		$(1)/usr/bin/
47
+	$(INSTALL_BIN) ./files/lcdgrilo.init $(1)/etc/init.d/lcdgrilo
48
+endef
49
+
50
+$(eval $(call BuildPackage,lcdgrilo))

+ 16
- 0
multimedia/lcdgrilo/files/lcdgrilo.init View File

@@ -0,0 +1,16 @@
1
+#!/bin/sh /etc/rc.common
2
+# Copyright (C) 2009-2012 OpenWrt.org
3
+
4
+START=60
5
+
6
+start() {
7
+	/usr/bin/lcdgrilo &
8
+	echo $! > /var/run/lcdgrilo.pid
9
+}
10
+
11
+stop() {
12
+	if [ ! -f /var/run/lcdgrilo.pid ]; then
13
+		return
14
+	fi
15
+	/bin/kill `cat /var/run/lcdgrilo.pid`
16
+}