|
@@ -0,0 +1,39 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2006-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=mktorrent
|
|
11
|
+PKG_VERSION:=1.0
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
|
14
|
+
|
|
15
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
16
|
+PKG_SOURCE_URL:=http://downloads.sourceforge.net/$(PKG_NAME)/
|
|
17
|
+PKG_MD5SUM:=0da00209da96a0dc39efbb6eb5b4d8ff
|
|
18
|
+
|
|
19
|
+include $(INCLUDE_DIR)/package.mk
|
|
20
|
+
|
|
21
|
+define Package/mktorrent
|
|
22
|
+ SUBMENU:=BitTorrent
|
|
23
|
+ SECTION:=net
|
|
24
|
+ CATEGORY:=Network
|
|
25
|
+ TITLE:=mktorrent
|
|
26
|
+ URL:=http://mktorrent.sourceforge.net/
|
|
27
|
+endef
|
|
28
|
+
|
|
29
|
+define Package/mktorrent/Description
|
|
30
|
+ mktorrent is a simple command line utility to create BitTorrent metainfo files.
|
|
31
|
+endef
|
|
32
|
+
|
|
33
|
+
|
|
34
|
+define Package/mktorrent/install
|
|
35
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
36
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/mktorrent $(1)/usr/bin
|
|
37
|
+endef
|
|
38
|
+
|
|
39
|
+$(eval $(call BuildPackage,mktorrent))
|