Browse Source

postgresql: fix potential snprintf issue

adopt buildroot commit: 3d3f70b567

spotted while reviewing buildroot changes to postgresql

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Dirk Neukirchen 9 years ago
parent
commit
bf119cb33b
1 changed files with 4 additions and 0 deletions
  1. 4
    0
      libs/postgresql/Makefile

+ 4
- 0
libs/postgresql/Makefile View File

@@ -66,6 +66,10 @@ define Package/pgsql-server/description
66 66
 PostgreSQL databases Server.
67 67
 endef
68 68
 
69
+PGSQL_CONFIG_VARS:= \
70
+	pgac_cv_snprintf_long_long_int_format="%lld" \
71
+	pgac_cv_snprintf_size_t_support=yes
72
+
69 73
 ifeq ($(CONFIG_USE_UCLIBC),y)
70 74
 # PostgreSQL does not build against uClibc with locales
71 75
 # enabled, due to an uClibc bug, see