Explorar el Código

forked-daapd: update to 22.2

Signed-off-by: Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
ejurgensen hace 10 años
padre
commit
bfc72eac16
Se han modificado 2 ficheros con 67 adiciones y 13 borrados
  1. 3
    3
      sound/forked-daapd/Makefile
  2. 64
    10
      sound/forked-daapd/files/forked-daapd.conf

+ 3
- 3
sound/forked-daapd/Makefile Ver fichero

@@ -8,9 +8,9 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=forked-daapd
11
-PKG_VERSION:=22.0
12
-PKG_RELEASE:=20141022
13
-PKG_REV:=61a4da215c05b621951aa3903d7d390fd1839537
11
+PKG_VERSION:=22.2
12
+PKG_RELEASE:=20150129
13
+PKG_REV:=77f206c11855d2d84688a6e7cd9c8932e8a89205
14 14
 
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
16 16
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)

+ 64
- 10
sound/forked-daapd/files/forked-daapd.conf Ver fichero

@@ -2,28 +2,37 @@
2 2
 #
3 3
 # For regular use, the most important setting to configure is "directories",
4 4
 # which should be the location of your media. Whatever user you have set as
5
-# "uid" must have read access to this location. Also make sure to add the user.
6
-# If the location is a network mount, please see the README.
5
+# "uid" must have read access to this location. If the location is a network
6
+# mount, please see the README.
7 7
 #
8 8
 # In all likelihood, that's all you need to do!
9 9
 
10 10
 general {
11 11
 	# Username
12
+	# Make sure the user has read access to the library directories you set
13
+ 	# below, and full access to the databases, log and local audio
12 14
 	uid = "daapd"
13
-	logfile = "/var/log/forked-daapd.log"
15
+
14 16
 	# Database location
15
-	db_path = "/var/run/forked-daapd.db"
17
+#	db_path = "/var/cache/forked-daapd/songs3.db"
18
+
19
+	# Log file and level
16 20
 	# Available levels: fatal, log, warning, info, debug, spam
21
+	logfile = "/var/log/forked-daapd.log"
17 22
 	loglevel = log
23
+
18 24
 	# Admin password for the non-existent web interface
19 25
 	admin_password = "unused"
26
+
20 27
 	# Enable/disable IPv6
21 28
 	ipv6 = no
22
-	# Location of DAAP cache
23
-	daapcache_path = "/var/run/daapcache.db"
29
+
30
+	# Location of cache database
31
+#	cache_path = "/var/cache/forked-daapd/cache.db"
32
+
24 33
 	# DAAP requests that take longer than this threshold (in msec) get their
25 34
 	# replies cached for next time. Set to 0 to disable caching.
26
-#	daapcache_threshold = 1000
35
+#	cache_daap_threshold = 1000
27 36
 }
28 37
 
29 38
 # Library configuration
@@ -31,8 +40,10 @@ library {
31 40
 	# Name of the library as displayed by the clients
32 41
 	# %h: hostname, %v: version
33 42
 	name = "My Music on %h"
43
+
34 44
 	# TCP port to listen on. Default port is 3689 (daap)
35 45
 	port = 3689
46
+
36 47
 	# Password for the library. Optional.
37 48
 #	password = ""
38 49
 
@@ -80,11 +91,22 @@ library {
80 91
 	# forked-daapd will look for jpg and png files with these base names
81 92
 #	artwork_basenames = { "artwork", "cover", "Folder" }
82 93
 
94
+	# Enable searching for artwork corresponding to each individual media
95
+	# file instead of only looking for album artwork. This is disabled by
96
+	# default to reduce cache size.
97
+#	artwork_individual = false
98
+
83 99
 	# File types the scanner should ignore
84 100
 	# Non-audio files will never be added to the database, but here you
85 101
 	# can prevent the scanner from even probing them. This might improve
86
-	# scan time. By default .db and .ini are ignored.
87
-#	filetypes_ignore = { ".db", ".ini" }
102
+	# scan time. By default .db, .ini, .db-journal and .pdf are ignored.
103
+#	filetypes_ignore = { ".db", ".ini", ".db-journal", ".pdf" }
104
+
105
+	# File paths the scanner should ignore
106
+	# If you want to exclude files on a more advanced basis you can enter
107
+	# one or more POSIX regular expressions, and any file with a matching
108
+	# path will be ignored.
109
+#	filepath_ignore = { "myregex" }
88 110
 
89 111
 	# Disable startup file scanning
90 112
 	# When forked-daapd starts it will do an initial file scan of your
@@ -93,7 +115,7 @@ library {
93 115
 	# initial file scan and save some system ressources. Disabling this scan
94 116
 	# may lead to forked-daapd's database coming out of sync with the
95 117
 	# library. If that happens read the instructions in the README on how
96
-	# to trigger a full rescan.
118
+	# to trigger a rescan.
97 119
 #	filescan_disable = false
98 120
 
99 121
 	# Should iTunes metadata override ours?
@@ -110,8 +132,10 @@ library {
110 132
 audio {
111 133
 	# Name - used in the speaker list in Remote
112 134
 	nickname = "OpenWrt"
135
+
113 136
 	# Audio device name for local audio output
114 137
 #	card = "default"
138
+
115 139
 	# Mixer channel to use for volume control - ALSA/Linux only
116 140
 	# If not set, PCM will be used if available, otherwise Master.
117 141
 #	mixer = ""
@@ -123,6 +147,7 @@ audio {
123 147
 	# forked-daapd's volume goes to 11! If that's more than you can handle
124 148
 	# you can set a lower value here
125 149
 #	max_volume = 11
150
+
126 151
 	# AirPlay password
127 152
 #	password = "s1kr3t"
128 153
 #}
@@ -131,9 +156,38 @@ audio {
131 156
 spotify {
132 157
 	# Directory where user settings should be stored (credentials)
133 158
 #	settings_dir = "/var/cache/forked-daapd/libspotify"
159
+
134 160
 	# Cache directory
135 161
 #	cache_dir = "/tmp"
162
+
136 163
 	# Set preferred bitrate for music streaming
137 164
 	# 0: No preference (default), 1: 96kbps, 2: 160kbps, 3: 320kbps
138 165
 #	bitrate = 0
139 166
 }
167
+
168
+# SQLite configuration (allows to modify the operation of the SQLite databases)
169
+# Make sure to read the SQLite documentation for the corresponding PRAGMA statements as
170
+# changing them from the defaults may increase the possibility of database corruptions!
171
+# By default the SQLite default values are used. 
172
+sqlite {
173
+	# Cache size in number of db pages for the library database
174
+	# (SQLite default page size is 1024 bytes and cache size is 2000 pages)
175
+#	pragma_cache_size_library = 2000
176
+	
177
+	# Cache size in number of db pages for the daap cache database
178
+	# (SQLite default page size is 1024 bytes and cache size is 2000 pages)
179
+#	pragma_cache_size_cache = 2000
180
+	
181
+	# Sets the journal mode for the database
182
+	# DELETE (default), TRUNCATE, PERSIST, MEMORY, WAL, OFF 
183
+#	pragma_journal_mode = DELETE
184
+	
185
+	# Change the setting of the "synchronous" flag
186
+	# 0: OFF, 1: NORMAL, 2: FULL (default)
187
+#	pragma_synchronous = 2
188
+
189
+	# Should the database be vacuumed on startup? (increases startup time,
190
+	# but may reduce database size). Default is yes.
191
+#	vacuum = yes
192
+}
193
+