瀏覽代碼

Merge pull request #378 from Vasilis/update_lispmob

lispmob: Update to 0.4.1
sbyx 10 年之前
父節點
當前提交
c003b653a0
共有 1 個文件被更改,包括 56 次插入0 次删除
  1. 56
    0
      net/lispmob/Makefile

+ 56
- 0
net/lispmob/Makefile 查看文件

@@ -0,0 +1,56 @@
1
+#
2
+# Copyright (C) 2012-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=lispmob
11
+PKG_REV:=180aa39d338a00bb532e421de7f8513492cf2e8b
12
+PKG_VERSION:=0.4
13
+PKG_RELEASE:=1
14
+
15
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
16
+PKG_SOURCE_URL:=git://github.com/LISPmob/lispmob.git
17
+PKG_SOURCE_PROTO:=git
18
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
19
+PKG_SOURCE_VERSION:=$(PKG_REV)
20
+
21
+PKG_LICENSE:=GPLv2
22
+PKG_LICENSE_FILES:=LICENSE
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+
26
+define Package/lispd/default
27
+  MAINTAINER:=Vasileios Lakafosis <lakafv@gmail.com>
28
+  URL:=http://lisp.cisco.com/
29
+endef
30
+
31
+define Package/lispd
32
+  SECTION:=net
33
+  CATEGORY:=Network
34
+  TITLE:=Locator/ID separation protocol (using TUN)
35
+  URL:=https://github.com/LISPmob
36
+  DEPENDS:= +librt +libopenssl +confuse +kmod-tun +uci +kmod-ipv6
37
+  $(call Package/lispd/default)
38
+endef
39
+
40
+define Package/lispd/description
41
+  This packet provides support for the Locator-ID Seperation Protocol.
42
+endef
43
+
44
+MAKE_FLAGS += \
45
+	platform=openwrt
46
+
47
+define Package/lispd/install
48
+	$(INSTALL_DIR) $(1)/usr/sbin
49
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/lispd/lispd $(1)/usr/sbin/
50
+	$(INSTALL_DIR) $(1)/etc/config
51
+	$(INSTALL_CONF) $(PKG_BUILD_DIR)/openWRT/lispd.uci.example $(1)/etc/config/lispd
52
+	$(INSTALL_DIR) $(1)/etc/init.d
53
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/openWRT/openwrt.init.script $(1)/etc/init.d/lisp
54
+endef
55
+
56
+$(eval $(call BuildPackage,lispd))