Browse Source

bridge-utils: fix musl compatibility

Add missing includes to libbridge.h to define struct timeval and the
required u_int*_t types under musl.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Jo-Philipp Wich 9 years ago
parent
commit
c10f93b913
2 changed files with 12 additions and 1 deletions
  1. 1
    1
      net/bridge-utils/Makefile
  2. 11
    0
      net/bridge-utils/patches/100-musl-compat.patch

+ 1
- 1
net/bridge-utils/Makefile View File

@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
10 10
 
11 11
 PKG_NAME:=bridge-utils
12 12
 PKG_VERSION:=1.5
13
-PKG_RELEASE:=4
13
+PKG_RELEASE:=5
14 14
 
15 15
 PKG_SOURCE_PROTO:=git
16 16
 PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/shemminger/bridge-utils.git

+ 11
- 0
net/bridge-utils/patches/100-musl-compat.patch View File

@@ -0,0 +1,11 @@
1
+--- a/libbridge/libbridge.h
2
++++ b/libbridge/libbridge.h
3
+@@ -19,6 +19,8 @@
4
+ #ifndef _LIBBRIDGE_H
5
+ #define _LIBBRIDGE_H
6
+ 
7
++#include <sys/types.h>
8
++#include <sys/select.h>
9
+ #include <sys/socket.h>
10
+ #include <netinet/in.h>
11
+ #include <linux/if.h>