Browse Source

Currently tinc init script will delete the generated configuration folder and then check if it will not exists in order to create it.

Alessio Caiazza 10 years ago
parent
commit
c1195229df
2 changed files with 3 additions and 5 deletions
  1. 1
    1
      net/tinc/Makefile
  2. 2
    4
      net/tinc/files/tinc.init

+ 1
- 1
net/tinc/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=tinc
11 11
 PKG_VERSION:=1.0.24
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://www.tinc-vpn.org/packages

+ 2
- 4
net/tinc/files/tinc.init View File

@@ -135,10 +135,8 @@ prepare_net() {
135 135
 
136 136
 	section_enabled "$s" || return 1
137 137
 
138
-        # rm old config
139
-        rm -rf "$TMP_TINC/$s/"
140
-
141
-	[ ! -d "$TMP_TINC/$s" ] && mkdir -p "$TMP_TINC/$s"
138
+	[ -d "$TMP_TINC/$s" ] && rm -rf "$TMP_TINC/$s/"
139
+	mkdir -p "$TMP_TINC/$s"
142 140
 	[ -d "/etc/tinc/$s" ] && cp -r "/etc/tinc/$s" "$TMP_TINC/"
143 141
 
144 142
 	# append flags