|
@@ -0,0 +1,58 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2009-2011 OpenWrt.org
|
|
3
|
+# Copyright (C) 2009 Jakob Pfeiffer
|
|
4
|
+# Copyright (C) 2014 Artem Makhutov
|
|
5
|
+#
|
|
6
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
7
|
+# See /LICENSE for more information.
|
|
8
|
+#
|
|
9
|
+
|
|
10
|
+include $(TOPDIR)/rules.mk
|
|
11
|
+
|
|
12
|
+PKG_NAME:=opennhrp
|
|
13
|
+PKG_VERSION:=0.14.1
|
|
14
|
+PKG_RELEASE:=1
|
|
15
|
+
|
|
16
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
17
|
+PKG_SOURCE_URL:=@SF/opennhrp
|
|
18
|
+PKG_MD5SUM:=eb42ddb13e07ceb415b9ebb8eaca28ee
|
|
19
|
+
|
|
20
|
+PKG_FIXUP:=autoreconf
|
|
21
|
+PKG_BUILD_PARALLEL:=1
|
|
22
|
+PKG_INSTALL:=1
|
|
23
|
+
|
|
24
|
+include $(INCLUDE_DIR)/package.mk
|
|
25
|
+
|
|
26
|
+define Package/opennhrp
|
|
27
|
+ SECTION:=net
|
|
28
|
+ CATEGORY:=Network
|
|
29
|
+ SUBMENU:=VPN
|
|
30
|
+ DEPENDS:=+libcares +ipsec-tools +ip +kmod-gre
|
|
31
|
+ KCONFIG:=CONFIG_ARPD=y
|
|
32
|
+ TITLE:=NBMA Next Hop Resolution Protocol
|
|
33
|
+ URL:=http://opennhrp.sourceforge.net/
|
|
34
|
+endef
|
|
35
|
+
|
|
36
|
+define Package/opennhrp/description
|
|
37
|
+ OpenNHRP implements NBMA Next Hop Resolution Protocol (as defined in RFC 2332).
|
|
38
|
+ It makes it possible to create dynamic multipoint VPN Linux router using NHRP,
|
|
39
|
+ GRE and IPsec. It aims to be Cisco DMVPN compatible.
|
|
40
|
+endef
|
|
41
|
+
|
|
42
|
+define Package/opennhrp/conffiles
|
|
43
|
+/etc/opennhrp/opennhrp.conf
|
|
44
|
+endef
|
|
45
|
+
|
|
46
|
+define Package/opennhrp/install
|
|
47
|
+ $(INSTALL_DIR) $(1)/usr/sbin
|
|
48
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/opennhrp{,ctl} $(1)/usr/sbin/
|
|
49
|
+ $(INSTALL_DIR) $(1)/etc/opennhrp
|
|
50
|
+ $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/opennhrp/opennhrp.conf $(1)/etc/opennhrp/
|
|
51
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/opennhrp-script $(1)/etc/opennhrp/
|
|
52
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/racoon-ph1down.sh $(1)/etc/opennhrp/
|
|
53
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/racoon-ph1dead.sh $(1)/etc/opennhrp/
|
|
54
|
+ $(INSTALL_DIR) $(1)/etc/init.d
|
|
55
|
+ $(INSTALL_BIN) ./files/opennhrp.init $(1)/etc/init.d/opennhrp
|
|
56
|
+endef
|
|
57
|
+
|
|
58
|
+$(eval $(call BuildPackage,opennhrp))
|