Browse Source

Merge pull request #1201 from luizluca/ruby_fixyaml

ruby: fix build when libyaml is present
Luiz Angelo Daros de Luca 10 years ago
parent
commit
c424a6b66f
1 changed files with 4 additions and 4 deletions
  1. 4
    4
      lang/ruby/Makefile

+ 4
- 4
lang/ruby/Makefile View File

@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
11 11
 
12 12
 PKG_NAME:=ruby
13 13
 PKG_VERSION:=2.2.2
14
-PKG_RELEASE:=1
14
+PKG_RELEASE:=2
15 15
 
16 16
 PKG_LIBVER:=2.2
17 17
 
@@ -575,7 +575,7 @@ endef
575 575
 define Package/ruby-psych
576 576
 $(call Package/ruby/Default)
577 577
   TITLE+=YAML parser and emitter
578
-  DEPENDS:=ruby +ruby-bigdecimal +ruby-datetime +ruby-misc +ruby-enc
578
+  DEPENDS:=ruby +ruby-bigdecimal +ruby-datetime +ruby-misc +ruby-enc +libyaml
579 579
 endef
580 580
 
581 581
 define Package/ruby-psych/description
@@ -803,6 +803,7 @@ HOST_CONFIGURE_ARGS += \
803 803
 	--disable-install-rdoc \
804 804
 	--disable-install-capi \
805 805
 	--with-static-linked-ext \
806
+	--with-out-ext=tk,tk/tkutil,win32,win32ole,dbm,gdbm,readline \
806 807
 
807 808
 # even not used, host build with restricted exts results in gems not being
808 809
 # compiling for target (probably some cross compiling problem like checking
@@ -819,6 +820,7 @@ CONFIGURE_ARGS += \
819 820
 	--disable-install-capi \
820 821
 	--with-ruby-version=minor \
821 822
 	--with-iconv-dir=$(ICONV_PREFIX) \
823
+	--with-out-ext=tk,tk/tkutil,win32,win32ole
822 824
 
823 825
 ifndef CONFIG_RUBY_DIGEST_USE_OPENSSL
824 826
 CONFIGURE_ARGS += \
@@ -880,7 +882,6 @@ define Package/ruby-datetime/install
880 882
 	( cd $(PKG_INSTALL_DIR); $(TAR) -cf - \
881 883
 		usr/lib/ruby/$(PKG_LIBVER)/time.rb \
882 884
 		usr/lib/ruby/$(PKG_LIBVER)/date.rb \
883
-		usr/lib/ruby/$(PKG_LIBVER)/date/ \
884 885
 		usr/lib/ruby/$(PKG_LIBVER)/*/date_core.so \
885 886
 	) | ( cd $(1); $(TAR) -xf - )
886 887
 endef
@@ -1258,7 +1259,6 @@ endef
1258 1259
 
1259 1260
 define Package/ruby-socket/install
1260 1261
 	( cd $(PKG_INSTALL_DIR); $(TAR) -cf - \
1261
-		usr/lib/ruby/$(PKG_LIBVER)/gserver.rb \
1262 1262
 		usr/lib/ruby/$(PKG_LIBVER)/ipaddr.rb \
1263 1263
 		usr/lib/ruby/$(PKG_LIBVER)/resolv-replace.rb \
1264 1264
 		usr/lib/ruby/$(PKG_LIBVER)/resolv.rb \