Просмотр исходного кода

libimobiledevice, usbmuxd, libplist, libusbmuxd: move to github

Signed-off-by: Lukasz Baj <l.baj@radytek.com>
Lukasz Baj 10 лет назад
Родитель
Сommit
c4f68cee5a
4 измененных файлов: 343 добавлений и 0 удалений
  1. 96
    0
      libs/libimobiledevice/Makefile
  2. 105
    0
      libs/libplist/Makefile
  3. 90
    0
      libs/libusbmuxd/Makefile
  4. 52
    0
      utils/usbmuxd/Makefile

+ 96
- 0
libs/libimobiledevice/Makefile Просмотреть файл

@@ -0,0 +1,96 @@
1
+#
2
+# Copyright (C) 2012-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=libimobiledevice
11
+PKG_VERSION:=1.1.6
12
+PKG_RELEASE:=1
13
+
14
+PKG_MAINTAINER:=Lukasz Baj <l.baj@radytek.com>
15
+PKG_LICENSE:=LGPL-2.1+
16
+PKG_LICENSE_FILE:=COPYING.LESSER
17
+
18
+PKG_SOURCE_PROTO:=git
19
+PKG_SOURCE_URL:=https://github.com/libimobiledevice/libimobiledevice.git
20
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
21
+PKG_SOURCE_VERSION:=9732d275d00bb1200d2b6180d94814a1a7fb7696
22
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
23
+
24
+PKG_FIXUP:=autoreconf
25
+PKG_INSTALL:=1
26
+
27
+include $(INCLUDE_DIR)/package.mk
28
+include $(INCLUDE_DIR)/nls.mk
29
+$(call include_mk, python-package.mk)
30
+
31
+define Package/libimobiledevice/Default
32
+  TITLE:=A library that talks to Apple devices.
33
+  URL:=http://www.libimobiledevice.org/
34
+endef
35
+
36
+define Package/libimobiledevice/Default/description
37
+  libimobiledevice is a software library that talks the protocols to support
38
+  iPhone®, iPod Touch®, iPad® and Apple TV® devices.
39
+endef
40
+
41
+define Package/libimobiledevice
42
+  $(call Package/libimobiledevice/Default)
43
+  SECTION:=libs
44
+  CATEGORY:=Libraries
45
+  DEPENDS:=$(ICONV_DEPENDS) +libplist +libusbmuxd +libopenssl +libcrypto
46
+endef
47
+
48
+define Package/libimobiledevice/description
49
+  $(call Package/libimobiledevice/Default/description)
50
+endef
51
+
52
+define Package/libimobiledevice-utils
53
+  $(call Package/libimobiledevice/Default)
54
+  SECTION:=utils
55
+  CATEGORY:=Utilities
56
+  DEPENDS:=+libimobiledevice
57
+endef
58
+
59
+define Package/libimobiledevice-utils/description
60
+  $(call Package/libimobiledevice/Default/description)
61
+  This package contains the libimobiledevice utilities.
62
+endef
63
+
64
+CONFIGURE_VARS += \
65
+	libusbmuxd_CFLAGS="-I$(STAGING_DIR)/usr/include" \
66
+	libusbmuxd_LIBS="-L$(STAGING_DIR)/usr/lib -lusbmuxd" \
67
+	openssl_CFLAGS=" " \
68
+	openssl_LIBS="-L$(STAGING_DIR)/usr/lib -lssl -lcrypto"
69
+
70
+CONFIGURE_ARGS += \
71
+	--without-cython \
72
+	--disable-largefile
73
+
74
+TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
75
+
76
+define Build/InstallDev
77
+	$(INSTALL_DIR) $(1)/usr/include
78
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/libimobiledevice $(1)/usr/include/
79
+	$(INSTALL_DIR) $(1)/usr/lib
80
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libimobiledevice.{a,la,so*} $(1)/usr/lib/
81
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
82
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libimobiledevice-*.pc $(1)/usr/lib/pkgconfig/
83
+endef
84
+
85
+define Package/libimobiledevice/install
86
+	$(INSTALL_DIR) $(1)/usr/lib
87
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libimobiledevice.so.* $(1)/usr/lib/
88
+endef
89
+
90
+define Package/libimobiledevice-utils/install
91
+	$(INSTALL_DIR) $(1)/usr/bin
92
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/idevice* $(1)/usr/bin/
93
+endef
94
+
95
+$(eval $(call BuildPackage,libimobiledevice))
96
+$(eval $(call BuildPackage,libimobiledevice-utils))

+ 105
- 0
libs/libplist/Makefile Просмотреть файл

@@ -0,0 +1,105 @@
1
+#
2
+# Copyright (C) 2012-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=libplist
11
+PKG_VERSION:=1.11
12
+PKG_RELEASE:=1
13
+
14
+PKG_MAINTAINER:=Lukasz Baj <l.baj@radytek.com>
15
+PKG_LICENSE:=LGPL-2.1+
16
+PKG_LICENSE_FILE:=COPYING.LESSER
17
+
18
+PKG_SOURCE_PROTO:=git
19
+PKG_SOURCE_URL:=https://github.com/libimobiledevice/libplist.git
20
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
21
+PKG_SOURCE_VERSION:=063c629baef6028e84838f77fd1401b05e41dc58
22
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
23
+
24
+PKG_FIXUP:=autoreconf
25
+PKG_INSTALL:=1
26
+
27
+include $(INCLUDE_DIR)/package.mk
28
+
29
+define Package/libplist/Default
30
+  TITLE:=Apple property list
31
+  URL:=http://www.libimobiledevice.org/
32
+endef
33
+
34
+define Package/libplist/Default/description
35
+  A library to handle Apple Property List format whereas it's binary or XML
36
+endef
37
+
38
+define Package/libplist
39
+  $(call Package/libplist/Default)
40
+  SECTION:=libs
41
+  CATEGORY:=Libraries
42
+  DEPENDS:=+libxml2
43
+  TITLE+= library
44
+endef
45
+
46
+define Package/libplist/description
47
+  $(call Package/libplist/Default/description)
48
+endef
49
+
50
+define Package/libplistcxx
51
+  $(call Package/libplist/Default)
52
+  SECTION:=libs
53
+  CATEGORY:=Libraries
54
+  DEPENDS:=+libplist +libstdcpp
55
+  TITLE+= C++ library
56
+endef
57
+
58
+define Package/libplistcxx/description
59
+  $(call Package/libplist/Default/description)
60
+  This package contains the libplist C++ shared library.
61
+endef
62
+
63
+define Package/libplist-utils
64
+  $(call Package/libplist/Default)
65
+  SECTION:=utils
66
+  CATEGORY:=Utilities
67
+  DEPENDS:=+libplist
68
+  TITLE+= converter
69
+endef
70
+
71
+define Package/libplist-utils/description
72
+  $(call Package/libplist/Default/description)
73
+  This package contains the libplist utilities.
74
+endef
75
+
76
+CONFIGURE_ARGS += \
77
+	--without-cython
78
+
79
+define Build/InstallDev
80
+	$(INSTALL_DIR) $(1)/usr/include
81
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/plist $(1)/usr/include/
82
+	$(INSTALL_DIR) $(1)/usr/lib
83
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libplist*.so* $(1)/usr/lib/
84
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
85
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libplist*.pc $(1)/usr/lib/pkgconfig/
86
+endef
87
+
88
+define Package/libplist/install
89
+	$(INSTALL_DIR) $(1)/usr/lib
90
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libplist.so.* $(1)/usr/lib/
91
+endef
92
+
93
+define Package/libplistcxx/install
94
+	$(INSTALL_DIR) $(1)/usr/lib
95
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libplist++.so.* $(1)/usr/lib/
96
+endef
97
+
98
+define Package/libplist-utils/install
99
+	$(INSTALL_DIR) $(1)/usr/bin
100
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/plistutil $(1)/usr/bin/
101
+endef
102
+
103
+$(eval $(call BuildPackage,libplist))
104
+$(eval $(call BuildPackage,libplistcxx))
105
+$(eval $(call BuildPackage,libplist-utils))

+ 90
- 0
libs/libusbmuxd/Makefile Просмотреть файл

@@ -0,0 +1,90 @@
1
+#
2
+# Copyright (C) 2012-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=libusbmuxd
11
+PKG_VERSION:=1.0.9
12
+PKG_RELEASE:=1
13
+
14
+PKG_MAINTAINER:=Lukasz Baj <l.baj@radytek.com>
15
+PKG_LICENSE:=LGPL-2.1+
16
+PKG_LICENSE_FILE:=COPYING.LGPLv2.1
17
+
18
+PKG_SOURCE_PROTO:=git
19
+PKG_SOURCE_URL:=https://github.com/libimobiledevice/libusbmuxd.git
20
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
21
+PKG_SOURCE_VERSION:=ca68e3c287a8410fbef5280948a6d1d2255e0a89
22
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
23
+
24
+PKG_FIXUP:=autoreconf
25
+PKG_INSTALL:=1
26
+
27
+include $(INCLUDE_DIR)/package.mk
28
+
29
+define Package/libusbmuxd/Default
30
+  TITLE:=USB multiplexing daemon
31
+  URL:=http://www.libimobiledevice.org/
32
+endef
33
+
34
+define Package/libusbmuxd/Default/description
35
+  This daemon is in charge of multiplexing connections over USB to an iPhone or
36
+  iPod touch. To users, it means you can sync your music, contacts, photos, etc.
37
+  over USB. To developers, it means you can connect to any listening localhost
38
+  socket on the device. usbmuxd is not used for tethering data transfer, which
39
+  uses a dedicated USB interface as a virtual network device.
40
+endef
41
+
42
+define Package/libusbmuxd
43
+  $(call Package/libusbmuxd/Default)
44
+  SECTION:=libs
45
+  CATEGORY:=Libraries
46
+  TITLE+= library
47
+  DEPENDS:=+libplist +libpthread +libxml2 +zlib
48
+endef
49
+
50
+define Package/libusbmuxd/description
51
+  $(call Package/libusbmuxd/Default/description)
52
+  This package contains the libusbmuxd shared library.
53
+endef
54
+
55
+define Package/libusbmuxd-utils
56
+  $(call Package/libusbmuxd/Default)
57
+  SECTION:=utils
58
+  CATEGORY:=Utilities
59
+  TITLE+= utilies
60
+  DEPENDS:=+libusbmuxd
61
+endef
62
+
63
+define Package/libusbmuxd-utils/description
64
+  $(call Package/libusbmuxd/Default/description)
65
+  This package contains the libusbmuxd utilities.
66
+endef
67
+
68
+TARGET_CFLAGS += $(FPIC)
69
+
70
+define Build/InstallDev
71
+	$(INSTALL_DIR) $(1)/usr/include
72
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
73
+	$(INSTALL_DIR) $(1)/usr/lib
74
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libusbmuxd.so* $(1)/usr/lib/
75
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
76
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libusbmuxd.pc $(1)/usr/lib/pkgconfig/
77
+endef
78
+
79
+define Package/libusbmuxd/install
80
+	$(INSTALL_DIR) $(1)/usr/lib
81
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libusbmuxd.so.* $(1)/usr/lib/
82
+endef
83
+
84
+define Package/libusbmuxd-utils/install
85
+	$(INSTALL_DIR) $(1)/usr/bin
86
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/iproxy $(1)/usr/bin/
87
+endef
88
+
89
+$(eval $(call BuildPackage,libusbmuxd))
90
+$(eval $(call BuildPackage,libusbmuxd-utils))

+ 52
- 0
utils/usbmuxd/Makefile Просмотреть файл

@@ -0,0 +1,52 @@
1
+#
2
+# Copyright (C) 2012-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=usbmuxd
11
+PKG_VERSION:=1.0.8
12
+PKG_RELEASE:=2
13
+PKG_SOURCE_PROTO:=git
14
+
15
+PKG_MAINTAINER:=Lukasz Baj <l.baj@radytek.com>
16
+PKG_LICENSE:=GPL-2.0
17
+PKG_LICENSE_FILE:=COPYING.GPLv2
18
+
19
+PKG_SOURCE_URL:=https://github.com/libimobiledevice/usbmuxd.git
20
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
21
+PKG_SOURCE_VERSION:=2f6d9d5f7047d4dd5ea9970721ba902301621ab2
22
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
23
+
24
+PKG_FIXUP:=autoreconf
25
+PKG_INSTALL:=1
26
+
27
+include $(INCLUDE_DIR)/package.mk
28
+
29
+define Package/usbmuxd
30
+  SECTION:=utils
31
+  CATEGORY:=Utilities
32
+  TITLE:=USB multiplexing daemon
33
+  URL:=http://www.libimobiledevice.org/
34
+  DEPENDS:=+librt +libusb-1.0 +libusbmuxd +libcrypto +libopenssl +libimobiledevice
35
+endef
36
+
37
+define Package/usbmuxd/description
38
+  This daemon is in charge of multiplexing connections over USB to an iPhone or
39
+  iPod touch. To users, it means you can sync your music, contacts, photos, etc.
40
+  over USB. To developers, it means you can connect to any listening localhost
41
+  socket on the device. usbmuxd is not used for tethering data transfer, which
42
+  uses a dedicated USB interface as a virtual network device.
43
+endef
44
+
45
+TARGET_CFLAGS += $(FPIC)
46
+
47
+define Package/usbmuxd/install
48
+	$(INSTALL_DIR) $(1)/usr/sbin
49
+	$(CP) $(PKG_INSTALL_DIR)/usr/sbin/usbmuxd $(1)/usr/sbin/
50
+endef
51
+
52
+$(eval $(call BuildPackage,usbmuxd))