Browse Source

tmux: update to 2.1

Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
Maxim Storchak 9 years ago
parent
commit
c53c5306a6
2 changed files with 20 additions and 14 deletions
  1. 2
    2
      utils/tmux/Makefile
  2. 18
    12
      utils/tmux/patches/100-b64_ntop-conflict.patch

+ 2
- 2
utils/tmux/Makefile View File

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=tmux
11
-PKG_VERSION:=2.0
11
+PKG_VERSION:=2.1
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=https://github.com/tmux/tmux/releases/download/$(PKG_VERSION)
16
-PKG_MD5SUM:=9fb6b443392c3978da5d599f1e814eaa
16
+PKG_MD5SUM:=74a2855695bccb51b6e301383ad4818c
17 17
 PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
18 18
 
19 19
 PKG_LICENSE:=ISC

+ 18
- 12
utils/tmux/patches/100-b64_ntop-conflict.patch View File

@@ -1,6 +1,8 @@
1
+diff --git a/compat.h b/compat.h
2
+index 8666a1d..2a44a2b 100644
1 3
 --- a/compat.h
2 4
 +++ b/compat.h
3
-@@ -230,7 +230,9 @@ int	 	 daemon(int, int);
5
+@@ -223,7 +223,9 @@ int	 	 daemon(int, int);
4 6
  #ifndef HAVE_B64_NTOP
5 7
  /* b64_ntop.c */
6 8
  #undef b64_ntop /* for Cygwin */
@@ -11,17 +13,8 @@
11 13
  #endif
12 14
  
13 15
  #ifndef HAVE_FORKPTY
14
---- a/tty.c
15
-+++ b/tty.c
16
-@@ -1070,7 +1070,7 @@ tty_cmd_setselection(struct tty *tty, co
17
- 	off = 4 * ((ctx->num + 2) / 3) + 1; /* storage for base64 */
18
- 	buf = xmalloc(off);
19
- 
20
--	b64_ntop(ctx->ptr, ctx->num, buf, off);
21
-+	local_b64_ntop(ctx->ptr, ctx->num, buf, off);
22
- 	tty_putcode_ptr2(tty, TTYC_MS, "", buf);
23
- 
24
- 	free(buf);
16
+diff --git a/compat/b64_ntop.c b/compat/b64_ntop.c
17
+index 2b4dc2d..a1314ca 100644
25 18
 --- a/compat/b64_ntop.c
26 19
 +++ b/compat/b64_ntop.c
27 20
 @@ -122,7 +122,7 @@ static const char Pad64 = '=';
@@ -33,3 +26,16 @@
33 26
  	size_t datalength = 0;
34 27
  	uint8_t input[3];
35 28
  	uint8_t output[4];
29
+diff --git a/tty.c b/tty.c
30
+index 7be952c..06dedab 100644
31
+--- a/tty.c
32
++++ b/tty.c
33
+@@ -1134,7 +1134,7 @@ tty_cmd_setselection(struct tty *tty, const struct tty_ctx *ctx)
34
+ 	off = 4 * ((ctx->num + 2) / 3) + 1; /* storage for base64 */
35
+ 	buf = xmalloc(off);
36
+ 
37
+-	b64_ntop(ctx->ptr, ctx->num, buf, off);
38
++	local_b64_ntop(ctx->ptr, ctx->num, buf, off);
39
+ 	tty_putcode_ptr2(tty, TTYC_MS, "", buf);
40
+ 
41
+ 	free(buf);