Преглед изворни кода

libs/c-ares: Port from old packages, and update

libcares is a dependency of mosquitto, at least.

Imported existing packages makefile, updated from 1.7.4 to 1.10.0
Added License and Maintainer information

Signed-off-by: Karl Palsson <karlp@remake.is>
Karl Palsson пре 10 година
родитељ
комит
c5573ce4b3
1 измењених фајлова са 51 додато и 0 уклоњено
  1. 51
    0
      libs/c-ares/Makefile

+ 51
- 0
libs/c-ares/Makefile Прегледај датотеку

@@ -0,0 +1,51 @@
1
+#
2
+# Copyright (C) 2009-2010 OpenWrt.org
3
+# Copyright (C) 2009 Jakob Pfeiffer
4
+#
5
+# This is free software, licensed under the GNU General Public License v2.
6
+# See /LICENSE for more information.
7
+#
8
+
9
+include $(TOPDIR)/rules.mk
10
+
11
+PKG_NAME:=c-ares
12
+PKG_VERSION:=1.10.0
13
+PKG_RELEASE:=1
14
+PKG_LICENSE:=MIT
15
+
16
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
17
+PKG_SOURCE_URL:=http://c-ares.haxx.se/download
18
+PKG_MD5SUM:=1196067641411a75d3cbebe074fd36d8
19
+
20
+PKG_FIXUP:=autoreconf
21
+PKG_INSTALL:=1
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+
25
+define Package/libcares
26
+  SECTION:=libs
27
+  CATEGORY:=Libraries
28
+  TITLE:=Library for asyncronous DNS Requests (including name resolves)
29
+  URL:=http://c-ares.haxx.se/
30
+  MAINTAINER:=Karl Palsson <karlp@remake.is>
31
+endef
32
+
33
+define Package/libcares/description
34
+  c-ares is a C library for asynchronous DNS requests (including name resolves)
35
+
36
+C89 compatibility, MIT licensed, builds for and runs on POSIX, Windows,
37
+Netware, Android and many more operating systems.
38
+
39
+endef
40
+
41
+define Package/libcares/install
42
+	$(INSTALL_DIR) $(1)/usr/lib
43
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
44
+endef
45
+
46
+define Build/InstallDev
47
+	$(INSTALL_DIR) $(1)
48
+	$(CP) $(PKG_INSTALL_DIR)/* $(1)/
49
+endef
50
+
51
+$(eval $(call BuildPackage,libcares))