Browse Source

liblo: import from old packages feed

 - update to latest version (v0.28)
 - add license info
 - add myself as maintainer

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 10 years ago
parent
commit
c57058da44
1 changed files with 71 additions and 0 deletions
  1. 71
    0
      libs/liblo/Makefile

+ 71
- 0
libs/liblo/Makefile View File

@@ -0,0 +1,71 @@
1
+#
2
+# Copyright (C) 2010-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=liblo
11
+PKG_VERSION:=0.28
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=@SF/liblo
16
+PKG_MD5SUM:=e2a4391a08b49bb316c03e2034e06fa2
17
+
18
+PKG_LICENSE:=LGPL-2.1+
19
+PKG_LICENSE_FILE:=COPYING
20
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
21
+
22
+PKG_INSTALL:=1
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+
26
+define Package/liblo/Default
27
+  SUBMENU:=Sound
28
+  TITLE:=Lightweight Open Sound Control (OSC)
29
+  URL:=http://liblo.sourceforge.net/
30
+endef
31
+
32
+define Package/liblo
33
+$(call Package/liblo/Default)
34
+  SECTION:=libs
35
+  CATEGORY:=Libraries
36
+  TITLE+= library
37
+  DEPENDS:= +libpthread
38
+endef
39
+
40
+define Package/liblo-utils
41
+$(call Package/liblo/Default)
42
+  SECTION:=utils
43
+  CATEGORY:=Utilities
44
+  TITLE+= utilities
45
+  DEPENDS:= +liblo
46
+endef
47
+
48
+TARGET_CFLAGS += \
49
+	-Wno-error=maybe-uninitialized \
50
+
51
+define Build/InstallDev
52
+	$(INSTALL_DIR) $(1)/usr/include
53
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/lo $(1)/usr/include/
54
+	$(INSTALL_DIR) $(1)/usr/lib
55
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblo.* $(1)/usr/lib/
56
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
57
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/liblo.pc $(1)/usr/lib/pkgconfig/
58
+endef
59
+
60
+define Package/liblo/install
61
+	$(INSTALL_DIR) $(1)/usr/lib
62
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblo.so.* $(1)/usr/lib/
63
+endef
64
+
65
+define Package/liblo-utils/install
66
+	$(INSTALL_DIR) $(1)/usr/bin
67
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/osc{dump,send} $(1)/usr/bin/
68
+endef
69
+
70
+$(eval $(call BuildPackage,liblo))
71
+$(eval $(call BuildPackage,liblo-utils))