Browse Source

zabbix: update to 2.4.0, refresh patches

Signed-off-by: Christoph König <christoph.koenig@gmail.com>
Signed-off-by: Etienne CHAMPETIER <champetier.etienne@gmail.com>
Christoph König 10 years ago
parent
commit
c5f4701fbf

+ 3
- 3
admin/zabbix/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2006-2013 OpenWrt.org
2
+# Copyright (C) 2006-2014 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=zabbix
11
-PKG_VERSION:=2.2.6
11
+PKG_VERSION:=2.4.0
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=@SF/zabbix
16
-PKG_MD5SUM:=38bc2407f80053d71853bb3419da364a
16
+PKG_MD5SUM:=57d9bf72bf0732971e4540a402bfc6c6
17 17
 
18 18
 PKG_LICENSE:=GPL-2.0
19 19
 PKG_LICENSE_FILES:=COPYING

+ 5
- 5
admin/zabbix/patches/002-fix-res_send-on-uclibc.patch View File

@@ -13,15 +13,15 @@
13 13
  dnl *                                                               *
14 14
 --- a/src/libs/zbxsysinfo/common/net.c
15 15
 +++ b/src/libs/zbxsysinfo/common/net.c
16
-@@ -425,6 +425,7 @@ static int	dns_query(AGENT_REQUEST *requ
17
- 	if (-1 == res_init())	/* initialize always, settings might have changed */
16
+@@ -450,6 +450,7 @@ static int	dns_query(AGENT_REQUEST *requ
18 17
  		return SYSINFO_RET_FAIL;
18
+ 	}
19 19
  
20 20
 +#if defined(HAVE_RES_MKQUERY) && defined(HAVE_RES_SEND) 
21 21
  	if (-1 == (res = res_mkquery(QUERY, zone, C_IN, type, NULL, 0, NULL, buf, sizeof(buf))))
22
- 		return SYSINFO_RET_FAIL;
23
- 
24
-@@ -449,6 +450,11 @@ static int	dns_query(AGENT_REQUEST *requ
22
+ 	{
23
+ 		SET_MSG_RESULT(result, zbx_dsprintf(NULL, "Cannot create DNS query: %s", zbx_strerror(errno)));
24
+@@ -480,6 +481,11 @@ static int	dns_query(AGENT_REQUEST *requ
25 25
  	_res.retry = retry;
26 26
  
27 27
  	res = res_send(buf, res, answer.buffer, sizeof(answer.buffer));

+ 3
- 3
admin/zabbix/patches/002-uclibc_loadavg.patch View File

@@ -1,8 +1,8 @@
1 1
 --- a/src/libs/zbxsysinfo/linux/cpu.c
2 2
 +++ b/src/libs/zbxsysinfo/linux/cpu.c
3
-@@ -21,6 +21,45 @@
4
- #include "sysinfo.h"
5
- #include "stats.h"
3
+@@ -62,6 +62,45 @@ int	SYSTEM_CPU_DISCOVERY(AGENT_REQUEST *
4
+ 	return SYSINFO_RET_OK;
5
+ }
6 6
  
7 7
 +
8 8
 +/* uclibc and dietlibc do not have this junk -ReneR */

+ 2
- 1
admin/zabbix/patches/010-change-agentd-config.patch View File

@@ -50,11 +50,12 @@
50 50
  ### Option: HostnameItem
51 51
  #	Item used for generating Hostname if it is undefined. Ignored if Hostname is defined.
52 52
  #	Does not support UserParameters or aliases.
53
-@@ -240,7 +231,7 @@ Hostname=Zabbix server
53
+@@ -249,8 +240,8 @@ Hostname=Zabbix server
54 54
  # Include=
55 55
  
56 56
  # Include=/usr/local/etc/zabbix_agentd.userparams.conf
57 57
 -# Include=/usr/local/etc/zabbix_agentd.conf.d/
58
+ # Include=/usr/local/etc/zabbix_agentd.conf.d/*.conf
58 59
 +Include=/etc/zabbix_agentd.conf.d/
59 60
  
60 61
  ####### USER-DEFINED MONITORED PARAMETERS #######