Kaynağa Gözat

devel/automake: add new package (closes #2192)

Automake is a tool for automatically generating Makefile.in files compliant
with the GNU Coding Standards.

A new package automake is provided.

version 2:
	do not reference staging directory in distributed files
	copy only one version of automake
	resolve whitespace issues

CC: Michael Heimpold <mhei@heimpold.de>
Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
Heinrich Schuchardt 9 yıl önce
ebeveyn
işleme
c6ac1e3f76
1 değiştirilmiş dosya ile 61 ekleme ve 0 silme
  1. 61
    0
      devel/automake/Makefile

+ 61
- 0
devel/automake/Makefile Dosyayı Görüntüle

@@ -0,0 +1,61 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=automake
11
+PKG_VERSION:=1.15
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=@GNU/automake
15
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
16
+PKG_MD5SUM:=716946a105ca228ab545fc37a70df3a3
17
+PKG_MAINTAINER:=Heinrich Schuchardt <xypron.glpk@gmx.de>
18
+PKG_LICENSE:=GPL-3.0+
19
+
20
+PKG_INSTALL:=1
21
+
22
+include $(INCLUDE_DIR)/package.mk
23
+
24
+define Package/automake
25
+  SECTION:=devel
26
+  CATEGORY:=Development
27
+  TITLE:=automake
28
+  URL:=https://www.gnu.org/software/automake/
29
+  DEPENDS:=+autoconf +perlbase-thread +perlbase-attributes
30
+endef
31
+
32
+define Package/automake/description
33
+  Automake is a tool for automatically generating Makefile.in files compliant
34
+  with the GNU Coding Standards.
35
+endef
36
+
37
+define Package/automake/install
38
+	$(INSTALL_DIR) $(1)/usr/bin
39
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/automake-$(PKG_VERSION) \
40
+	  $(1)/usr/bin/automake
41
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aclocal-$(PKG_VERSION) \
42
+	  $(1)/usr/bin/aclocal
43
+	$(SED) 's|$(STAGING_DIR_HOST)|/usr|g' $(1)/usr/bin/automake
44
+	$(SED) 's|$(STAGING_DIR_HOST)|/usr|g' $(1)/usr/bin/aclocal
45
+	$(INSTALL_DIR) $(1)/usr/share/automake-$(PKG_VERSION)
46
+
47
+	for dir in \
48
+	  automake-$(PKG_VERSION) automake-$(PKG_VERSION)/Automake \
49
+	  automake-$(PKG_VERSION)/am aclocal \
50
+	  aclocal-$(PKG_VERSION) aclocal-$(PKG_VERSION)/internal \
51
+	; do \
52
+		$(INSTALL_DIR) $(1)/usr/share/$$$$dir; \
53
+		for file in $$$$(cd $(PKG_INSTALL_DIR) && \
54
+		  find usr/share/$$$$dir -maxdepth 1 -type f); do \
55
+			$(INSTALL_DATA) $$(PKG_INSTALL_DIR)/$$$$file \
56
+			$(1)/$$$$file; \
57
+		done; \
58
+	done
59
+endef
60
+
61
+$(eval $(call BuildPackage,automake))