Sfoglia il codice sorgente

python-pyasn1: new package

From the README:

This is an implementation of ASN.1 types and codecs in Python programming
language. It has been first written to support particular protocol (SNMP)
but then generalized to be suitable for a wide range of protocols
based on ASN.1 specification.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Jeffery To 9 anni fa
parent
commit
c839e23879
1 ha cambiato i file con 46 aggiunte e 0 eliminazioni
  1. 46
    0
      lang/python-pyasn1/Makefile

+ 46
- 0
lang/python-pyasn1/Makefile Vedi File

@@ -0,0 +1,46 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=pyasn1
11
+PKG_VERSION:=0.1.9
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/p/pyasn1
16
+PKG_MD5SUM:=f00a02a631d4016818659d1cc38d229a
17
+
18
+PKG_LICENSE:=BSD-2-Clause
19
+PKG_LICENSE_FILES:=LICENSE.txt
20
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
21
+
22
+include $(INCLUDE_DIR)/package.mk
23
+$(call include_mk, python-package.mk)
24
+
25
+define Package/python-pyasn1
26
+	SECTION:=lang
27
+	CATEGORY:=Languages
28
+	SUBMENU:=Python
29
+	TITLE:=python-pyasn1
30
+	URL:=http://pyasn1.sourceforge.net/
31
+	DEPENDS:=+python-light
32
+endef
33
+
34
+define Package/python-pyasn1/description
35
+This is an implementation of ASN.1 types and codecs in Python programming
36
+language. It has been first written to support particular protocol (SNMP)
37
+but then generalized to be suitable for a wide range of protocols
38
+based on ASN.1 specification.
39
+endef
40
+
41
+define Build/Compile
42
+	$(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
43
+endef
44
+
45
+$(eval $(call PyPackage,python-pyasn1))
46
+$(eval $(call BuildPackage,python-pyasn1))