Browse Source

Create youtube-dl package

Signed-off-by: Adrian Panella <ianchi74@outlook.com>
Adrian Panella 8 years ago
parent
commit
c87b4647c9
1 changed files with 45 additions and 0 deletions
  1. 45
    0
      multimedia/youtube-dl/Makefile

+ 45
- 0
multimedia/youtube-dl/Makefile View File

@@ -0,0 +1,45 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=youtube-dl
11
+PKG_VERSION:=2016.04.06
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://youtube-dl.org/downloads/$(PKG_VERSION)/
16
+PKG_MD5SUM:=6457b915a6df78deb6e730cc425f9695
17
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
18
+
19
+PKG_LICENSE:=Unlicense
20
+PKG_LICENSE_FILES:=LICENSE
21
+PKG_MAINTAINER:=Adrian Panella <ianchi74@outlook.com>
22
+
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+
26
+define Package/youtube-dl
27
+  SECTION:=multimedia
28
+  CATEGORY:=Multimedia
29
+  TITLE:=utility to download videos from YouTube.com
30
+  DEPENDS:=+python-openssl
31
+  URL:=https://youtube-dl.org
32
+endef
33
+
34
+define Package/youtube-dl/description
35
+  youtube-dl is a small command-line program to download videos 
36
+  from YouTube.com and a few more sites. 
37
+  It requires the Python interpreter.
38
+endef
39
+
40
+define Package/youtube-dl/install
41
+	$(INSTALL_DIR) $(1)/usr/bin
42
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/youtube-dl $(1)/usr/bin/
43
+endef
44
+
45
+$(eval $(call BuildPackage,youtube-dl))