Browse Source

mdnsresponder: bump to 567

Signed-off-by: Steven Barth <steven@midlink.org>
Steven Barth 9 years ago
parent
commit
c8c6157e7e

+ 2
- 2
net/mdnsresponder/Makefile View File

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=mDNSResponder
11
-PKG_VERSION:=561.1.1
11
+PKG_VERSION:=567
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=mDNSResponder-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://opensource.apple.com/tarballs/mDNSResponder/
16
-PKG_MD5SUM:=d4b56e22798d6f45e29b42cd6720ab6e
16
+PKG_MD5SUM:=6eff6d243a12a3d4b6fca03c05a9893b
17 17
 PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
18 18
 PKG_LICENSE:=Apache-2.0
19 19
 

+ 12
- 20
net/mdnsresponder/patches/001-cross_compile.patch View File

@@ -1,6 +1,6 @@
1 1
 --- a/Clients/Makefile
2 2
 +++ b/Clients/Makefile
3
-@@ -23,6 +23,8 @@
3
+@@ -27,6 +27,8 @@
4 4
  
5 5
  #############################################################################
6 6
  
@@ -9,22 +9,22 @@
9 9
  # On OS X the dns_sd library functions are included in libSystem, which is implicitly linked with every executable
10 10
  # If /usr/lib/libSystem.dylib exists, then we're on OS X, so we don't need also to link the "dns_sd" shared library
11 11
  ifneq "$(wildcard /usr/lib/libSystem.dylib)" ""
12
-@@ -42,10 +44,10 @@ build:
12
+@@ -46,10 +48,10 @@ build:
13 13
  	mkdir build
14 14
  
15 15
  build/dns-sd: build dns-sd.c ClientCommon.c
16
--	cc $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@
16
+-	$(CC) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@
17 17
 +	$(CC) $(CFLAGS) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@
18 18
  
19 19
  build/dns-sd64: build dns-sd.c ClientCommon.c
20
--	cc $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@ -m64
20
+-	$(CC) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@ -m64
21 21
 +	$(CC) $(CFLAGS) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@ -m64
22 22
  
23 23
  # Note, we can make a 'fat' version of dns-sd using 'lipo', as shown below, but we
24 24
  # don't, because we don't want or need a 'fat' version of dns-sd, because it will
25 25
 --- a/mDNSPosix/Makefile
26 26
 +++ b/mDNSPosix/Makefile
27
-@@ -54,10 +54,11 @@ COREDIR = ../mDNSCore
27
+@@ -54,11 +54,12 @@ COREDIR = ../mDNSCore
28 28
  SHAREDDIR ?= ../mDNSShared
29 29
  JDK = /usr/jdk
30 30
  
@@ -32,22 +32,14 @@
32 32
 +CC = @gcc
33 33
  BISON = @bison
34 34
  FLEX = @flex
35
+ ST = @strip
35 36
 -LD = ld -shared
36 37
 +LD = @ld
37 38
 +SOOPTS = -shared
38 39
  CP = cp
39 40
  RM = rm
40 41
  LN = ln -s -f
41
-@@ -82,7 +83,7 @@ else
42
- CFLAGS_DEBUG = -Os -DMDNS_DEBUGMSGS=0 
43
- OBJDIR ?= objects/prod
44
- BUILDDIR ?= build/prod
45
--STRIP = strip -S 
46
-+STRIP = @strip -S
47
- endif
48
- 
49
- # Configure per-OS peculiarities
50
-@@ -91,7 +92,7 @@ CFLAGS_DEBUG = -O0 -DMDNS_DEBUGMSGS=0
42
+@@ -92,7 +93,7 @@ CFLAGS_DEBUG = -O0 -DMDNS_DEBUGMSGS=0
51 43
  CFLAGS_OS = -DNOT_HAVE_DAEMON -DNOT_HAVE_SA_LEN -DNOT_HAVE_SOCKLEN_T -DNOT_HAVE_IF_NAMETOINDEX \
52 44
  	 -DLOG_PERROR=0 -D_XPG4_2 -D__EXTENSIONS__ -DHAVE_BROKEN_RECVIF_NAME -DTARGET_OS_SOLARIS
53 45
  CC = gcc
@@ -56,7 +48,7 @@
56 48
  LINKOPTS = -lsocket -lnsl -lresolv
57 49
  JAVACFLAGS_OS += -I$(JDK)/include/solaris
58 50
  ifneq ($(DEBUG),1)
59
-@@ -147,7 +148,8 @@ CFLAGS_OS = -DHAVE_IPV6 -no-cpp-precomp
51
+@@ -148,7 +149,8 @@ CFLAGS_OS = -DHAVE_IPV6 -no-cpp-precomp
60 52
  	-D__MAC_OS_X_VERSION_MIN_REQUIRED=__MAC_OS_X_VERSION_10_4 \
61 53
  	-D__APPLE_USE_RFC_2292 #-Wunreachable-code
62 54
  CC = gcc
@@ -66,7 +58,7 @@
66 58
  LINKOPTS = -lSystem
67 59
  LDSUFFIX = dylib
68 60
  JDK = /System/Library/Frameworks/JavaVM.framework/Home
69
-@@ -169,8 +171,9 @@ NSSLIBFILE  := $(NSSLIBNAME)-$(NSSVERSIO
61
+@@ -170,8 +172,9 @@ NSSLIBFILE  := $(NSSLIBNAME)-$(NSSVERSIO
70 62
  NSSLINKNAME := $(NSSLIBNAME).so.2
71 63
  NSSINSTPATH := /lib
72 64
  
@@ -77,7 +69,7 @@
77 69
  INSTBASE?=/usr
78 70
  STARTUPSCRIPTNAME?=mdns
79 71
  
80
-@@ -256,7 +259,7 @@ libdns_sd: setup $(BUILDDIR)/libdns_sd.$
72
+@@ -257,7 +260,7 @@ libdns_sd: setup $(BUILDDIR)/libdns_sd.$
81 73
  CLIENTLIBOBJS = $(OBJDIR)/dnssd_clientlib.c.so.o $(OBJDIR)/dnssd_clientstub.c.so.o $(OBJDIR)/dnssd_ipc.c.so.o
82 74
  
83 75
  $(BUILDDIR)/libdns_sd.$(LDSUFFIX): $(CLIENTLIBOBJS)
@@ -86,7 +78,7 @@
86 78
  	@$(STRIP) $@
87 79
  
88 80
  Clients: setup libdns_sd ../Clients/build/dns-sd
89
-@@ -291,7 +294,7 @@ InstalledManPages: $(MANPATH)/man8/mdnsd
81
+@@ -292,7 +295,7 @@ InstalledManPages: $(MANPATH)/man8/mdnsd
90 82
  InstalledClients: $(INSTBASE)/bin/dns-sd
91 83
  	@echo $+ " installed"
92 84
  
@@ -95,7 +87,7 @@
95 87
  	@echo $+ " installed"
96 88
  
97 89
  # Note: If daemon already installed, we make sure it's stopped before overwriting it
98
-@@ -346,19 +349,21 @@ $(INSTBASE)/bin/dns-sd: ../Clients/build
90
+@@ -347,19 +350,21 @@ $(INSTBASE)/bin/dns-sd: ../Clients/build
99 91
  
100 92
  $(NSSINSTPATH)/$(NSSLINKNAME): $(NSSINSTPATH)/$(NSSLIBFILE)
101 93
  	$(LN) $< $@

+ 12
- 12
net/mdnsresponder/patches/100-linux_fixes.patch View File

@@ -84,7 +84,7 @@
84 84
  }
85 85
 --- a/mDNSPosix/mDNSPosix.c
86 86
 +++ b/mDNSPosix/mDNSPosix.c
87
-@@ -136,7 +136,7 @@ mDNSlocal void SockAddrTomDNSAddr(const
87
+@@ -138,7 +138,7 @@ mDNSlocal void SockAddrTomDNSAddr(const
88 88
  
89 89
  // mDNS core calls this routine when it needs to send a packet.
90 90
  mDNSexport mStatus mDNSPlatformSendUDP(const mDNS *const m, const void *const msg, const mDNSu8 *const end,
@@ -93,7 +93,7 @@
93 93
                                         mDNSIPPort dstPort, mDNSBool useBackgroundTrafficClass)
94 94
  {
95 95
      int err = 0;
96
-@@ -574,9 +574,17 @@ mDNSlocal void FreePosixNetworkInterface
96
+@@ -583,9 +583,17 @@ mDNSlocal void FreePosixNetworkInterface
97 97
  {
98 98
      assert(intf != NULL);
99 99
      if (intf->intfName != NULL) free((void *)intf->intfName);
@@ -111,9 +111,9 @@
111 111
 +        assert(rv == 0);
112 112
 +      }
113 113
  #endif
114
-     free(intf);
115
- }
116
-@@ -703,6 +711,29 @@ mDNSlocal int SetupSocket(struct sockadd
114
+ 
115
+     // Move interface to the RecentInterfaces list for a minute
116
+@@ -724,6 +732,29 @@ mDNSlocal int SetupSocket(struct sockadd
117 117
              if (err < 0) { err = errno; perror("setsockopt - IP_MULTICAST_TTL"); }
118 118
          }
119 119
  
@@ -143,7 +143,7 @@
143 143
          // And start listening for packets
144 144
          if (err == 0)
145 145
          {
146
-@@ -784,6 +815,29 @@ mDNSlocal int SetupSocket(struct sockadd
146
+@@ -805,6 +836,29 @@ mDNSlocal int SetupSocket(struct sockadd
147 147
              if (err < 0) { err = errno; perror("setsockopt - IPV6_MULTICAST_HOPS"); }
148 148
          }
149 149
  
@@ -173,7 +173,7 @@
173 173
          // And start listening for packets
174 174
          if (err == 0)
175 175
          {
176
-@@ -815,7 +869,12 @@ mDNSlocal int SetupSocket(struct sockadd
176
+@@ -836,7 +890,12 @@ mDNSlocal int SetupSocket(struct sockadd
177 177
      }
178 178
  
179 179
      // Clean up
@@ -187,7 +187,7 @@
187 187
      assert((err == 0) == (*sktPtr != -1));
188 188
      return err;
189 189
  }
190
-@@ -994,7 +1053,7 @@ mDNSlocal mStatus OpenIfNotifySocket(int
190
+@@ -1026,7 +1085,7 @@ mDNSlocal mStatus OpenIfNotifySocket(int
191 191
      /* Subscribe the socket to Link & IP addr notifications. */
192 192
      mDNSPlatformMemZero(&snl, sizeof snl);
193 193
      snl.nl_family = AF_NETLINK;
@@ -196,7 +196,7 @@
196 196
      ret = bind(sock, (struct sockaddr *) &snl, sizeof snl);
197 197
      if (0 == ret)
198 198
          *pFD = sock;
199
-@@ -1072,11 +1131,18 @@ mDNSlocal mDNSu32       ProcessRoutingNo
199
+@@ -1104,11 +1163,18 @@ mDNSlocal mDNSu32       ProcessRoutingNo
200 200
          PrintNetLinkMsg(pNLMsg);
201 201
  #endif
202 202
  
@@ -217,7 +217,7 @@
217 217
  
218 218
          // Advance pNLMsg to the next message in the buffer
219 219
          if ((pNLMsg->nlmsg_flags & NLM_F_MULTI) != 0 && pNLMsg->nlmsg_type != NLMSG_DONE)
220
-@@ -1247,8 +1313,12 @@ mDNSexport mStatus mDNSPlatformInit(mDNS
220
+@@ -1279,8 +1345,12 @@ mDNSexport mStatus mDNSPlatformInit(mDNS
221 221
      if (err == mStatus_NoError) err = SetupSocket(&sa, zeroIPPort, 0, &m->p->unicastSocket6);
222 222
  #endif
223 223
  
@@ -230,7 +230,7 @@
230 230
  
231 231
      // Tell mDNS core about DNS Servers
232 232
      mDNS_Lock(m);
233
-@@ -1281,9 +1351,17 @@ mDNSexport void mDNSPlatformClose(mDNS *
233
+@@ -1313,9 +1383,17 @@ mDNSexport void mDNSPlatformClose(mDNS *
234 234
  {
235 235
      assert(m != NULL);
236 236
      ClearInterfaceList(m);
@@ -250,7 +250,7 @@
250 250
  #endif
251 251
  }
252 252
  
253
-@@ -1533,14 +1611,14 @@ mDNSexport mStatus    mDNSPlatformClearS
253
+@@ -1571,14 +1649,14 @@ mDNSexport mStatus    mDNSPlatformClearS
254 254
  mDNSexport mDNSu16 mDNSPlatformGetUDPPort(UDPSocket *sock)
255 255
  {
256 256
      (void) sock; // unused