Parcourir la source

acl: add ACL tools and libs

Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
Maxim Storchak il y a 10 ans
Parent
révision
c9b56fef35

+ 98
- 0
utils/acl/Makefile Voir le fichier

@@ -0,0 +1,98 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=acl
11
+PKG_REV:=f2a5f57a20ffa007abc1fa24df1f76e18b74a425
12
+PKG_VERSION:=20140610
13
+PKG_RELEASE:=1
14
+
15
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
16
+PKG_SOURCE_URL:=git://git.sv.gnu.org/acl.git
17
+PKG_SOURCE_PROTO:=git
18
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
19
+PKG_SOURCE_VERSION:=$(PKG_REV)
20
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
21
+PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
22
+PKG_INSTALL:=1
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+
26
+define Package/acl/Default
27
+  TITLE:=Access control list (ACL) manipulation
28
+  URL:=http://savannah.nongnu.org/projects/acl
29
+  SUBMENU:=Filesystem
30
+endef
31
+
32
+define Package/acl/Default/description
33
+  Access control list support
34
+endef
35
+
36
+define Package/acl
37
+$(call Package/acl/Default)
38
+  SECTION:=utils
39
+  CATEGORY:=Utilities
40
+  TITLE+=utils
41
+  DEPENDS:=+libacl
42
+endef
43
+
44
+define Package/libacl
45
+$(call Package/acl/Default)
46
+  SECTION:=libs
47
+  CATEGORY:=Libraries
48
+  TITLE+=library
49
+  DEPENDS:=+libattr
50
+  KCONFIG:= \
51
+    CONFIG_EXT4_FS_POSIX_ACL=y \
52
+    CONFIG_FS_POSIX_ACL=y \
53
+    CONFIG_HFSPLUS_FS_POSIX_ACL=y \
54
+    CONFIG_JFFS2_FS_POSIX_ACL=y \
55
+    CONFIG_JFS_POSIX_ACL=y \
56
+    CONFIG_TMPFS_POSIX_ACL=y \
57
+    CONFIG_XFS_POSIX_ACL=y \
58
+
59
+endef
60
+
61
+define Package/libacl/description
62
+$(call Package/acl/Default/description)
63
+ This package provides libacl
64
+endef
65
+
66
+define Package/acl/description
67
+$(call Package/acl/Default/description)
68
+ This package provides ACL manipulation utilities
69
+ - chacl
70
+ - getfacl
71
+ - setfacl
72
+endef
73
+
74
+CONFIGURE_ARGS += --enable-static --enable-shared
75
+
76
+define Build/Prepare
77
+	$(call Build/Prepare/Default)
78
+	(cd $(PKG_BUILD_DIR); ./autogen.sh;);
79
+endef
80
+
81
+define Package/acl/install
82
+	$(INSTALL_DIR) $(1)/usr/bin
83
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
84
+endef
85
+
86
+define Package/libacl/install
87
+	$(INSTALL_DIR) $(1)/usr/lib
88
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
89
+endef
90
+
91
+define Build/InstallDev
92
+	mkdir -p $(1)/usr/include
93
+	mkdir -p $(1)/usr/lib/pkgconfig
94
+	$(CP) -r $(PKG_INSTALL_DIR)/usr/{include,lib} $(1)/usr/
95
+endef
96
+
97
+$(eval $(call BuildPackage,acl))
98
+$(eval $(call BuildPackage,libacl))

+ 21
- 0
utils/acl/patches/100-no-gettext_configure.patch Voir le fichier

@@ -0,0 +1,21 @@
1
+diff --git a/configure.ac b/configure.ac
2
+index 2182e81..4836b3d 100644
3
+--- a/configure.ac
4
++++ b/configure.ac
5
+@@ -31,9 +31,6 @@ AC_FUNC_GCC_VISIBILITY
6
+ AM_PROG_AR
7
+ LT_INIT
8
+ 
9
+-AM_GNU_GETTEXT_VERSION([0.18.2])
10
+-AM_GNU_GETTEXT([external])
11
+-
12
+ AC_ARG_ENABLE([debug],
13
+ 	[AS_HELP_STRING([--enable-debug], [Enable extra debugging])])
14
+ AS_IF([test "x$enable_debug" = "xyes"],
15
+@@ -61,6 +58,5 @@ AC_CONFIG_COMMANDS([include/sys],
16
+ AC_CONFIG_FILES([
17
+ 	libacl.pc
18
+ 	Makefile
19
+-	po/Makefile.in
20
+ ])
21
+ AC_OUTPUT

+ 9
- 0
utils/acl/patches/101-no-gettext_autogen.patch Voir le fichier

@@ -0,0 +1,9 @@
1
+diff --git a/autogen.sh b/autogen.sh
2
+index a98a3c5..982aff1 100755
3
+--- a/autogen.sh
4
++++ b/autogen.sh
5
+@@ -1,4 +1,2 @@
6
+ #!/bin/sh -ex
7
+-po/update-potfiles
8
+-autopoint --force
9
+ exec autoreconf -f -i

+ 13
- 0
utils/acl/patches/102-no-gettext_Makefile.patch Voir le fichier

@@ -0,0 +1,13 @@
1
+diff --git a/Makefile.am b/Makefile.am
2
+index 47d2a4e..d02ee91 100644
3
+--- a/Makefile.am
4
++++ b/Makefile.am
5
+@@ -3,8 +3,6 @@ ACLOCAL_AMFLAGS = -I m4
6
+ EXTRA_DIST = \
7
+ 	exports
8
+ 
9
+-SUBDIRS = po
10
+-
11
+ AM_CPPFLAGS = \
12
+ 	-I$(top_builddir)/include \
13
+ 	-I$(top_srcdir)/include \