Browse Source

micropython: simplify makefile + update

Platform detection now done upstream.

Signed-off-by: Roger D <rogerdammit@gmail.com>
Roger 10 years ago
parent
commit
ca423611e8
1 changed files with 3 additions and 19 deletions
  1. 3
    19
      lang/micropython/Makefile

+ 3
- 19
lang/micropython/Makefile View File

@@ -8,7 +8,7 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=micropython
11
-PKG_VERSION=1.3.1-20140830-$(PKG_SOURCE_VERSION)
11
+PKG_VERSION=1.3.1-20140904-$(PKG_SOURCE_VERSION)
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
@@ -17,7 +17,7 @@ PKG_LICENSE_FILES:=LICENSE
17 17
 
18 18
 PKG_SOURCE_PROTO:=git
19 19
 PKG_SOURCE_URL:=https://github.com/micropython/micropython.git
20
-PKG_SOURCE_VERSION:=90fad65d2fb2695e1941296a6a55c175982299f2
20
+PKG_SOURCE_VERSION:=b534e1b9f14c189d2cef209d40f598e62164694a
21 21
 
22 22
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
23 23
 PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
@@ -39,25 +39,9 @@ define Package/micropython/description
39 39
  that is optimised to run on a microcontroller (and low power computers).
40 40
 endef
41 41
 
42
-# This is necessary for MIPS only (based on https://github.com/pfalcon/micropython/blob/cross/unix/build-mips.sh)
43
-MIPS_CFLAGS_EXTRA += -DMICROPY_GCREGS_SETJMP=1
44
-
45
-ifeq ($(ARCH),mips)
46
-       TARGET_CFLAGS_EXTRA += $(MIPS_CFLAGS_EXTRA)
47
-endif
48
-
49
-ifeq ($(ARCH),mipsel)
50
-       TARGET_CFLAGS_EXTRA += $(MIPS_CFLAGS_EXTRA)
51
-endif
52
-
53
-ifneq ($(ARCH),x86_64)
54
-       TARGET_CFLAGS_EXTRA += -DMICROPY_EMIT_X64=0
55
-endif
56
-
57 42
 MAKE_FLAGS += \
58 43
        -C $(PKG_BUILD_DIR)/unix \
59
-       MICROPY_USE_READLINE=0 \
60
-       CFLAGS_EXTRA="$(TARGET_CFLAGS_EXTRA)" 
44
+       MICROPY_USE_READLINE=0
61 45
 
62 46
 define Package/micropython/install
63 47
 	$(INSTALL_DIR) $(1)/usr/bin