|
@@ -0,0 +1,72 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=libnetfilter_cthelper
|
|
11
|
+PKG_VERSION:=1.0.0
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
15
|
+PKG_SOURCE_URL:= \
|
|
16
|
+ http://www.netfilter.org/projects/libnetfilter_cthelper/files/ \
|
|
17
|
+ ftp://ftp.netfilter.org/pub/libnetfilter_cthelper/ \
|
|
18
|
+ http://mirrors.evolva.ro/netfilter.org/libnetfilter_cthelper/
|
|
19
|
+PKG_MD5SUM:=b2efab1a3a198a5add448960ba011acd
|
|
20
|
+
|
|
21
|
+PKG_LICENSE:=GPL-2.0+
|
|
22
|
+PKG_LICENSE_FILES:=COPYING
|
|
23
|
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
|
|
24
|
+
|
|
25
|
+PKG_FIXUP:=autoreconf
|
|
26
|
+PKG_INSTALL:=1
|
|
27
|
+
|
|
28
|
+include $(INCLUDE_DIR)/package.mk
|
|
29
|
+
|
|
30
|
+define Package/libnetfilter-cthelper
|
|
31
|
+ CATEGORY:=Libraries
|
|
32
|
+ SECTION:=libs
|
|
33
|
+ TITLE:=API to connection tracking helper infrastructure
|
|
34
|
+ URL:=http://www.netfilter.org/projects/libnetfilter_cthelper/
|
|
35
|
+ DEPENDS:=+libmnl
|
|
36
|
+endef
|
|
37
|
+
|
|
38
|
+define Package/libnetfilter-cthelper/description
|
|
39
|
+ libnetfilter_cthelper is the userspace library that provides the programming
|
|
40
|
+ interface to the user-space helper infrastructure available since Linux kernel
|
|
41
|
+ 3.6.
|
|
42
|
+ With this library, you register, configure, enable and disable user-space
|
|
43
|
+ helpers.
|
|
44
|
+endef
|
|
45
|
+
|
|
46
|
+TARGET_CFLAGS += $(FPIC)
|
|
47
|
+
|
|
48
|
+CONFIGURE_ARGS += \
|
|
49
|
+ --enable-static \
|
|
50
|
+ --enable-shared \
|
|
51
|
+
|
|
52
|
+define Build/InstallDev
|
|
53
|
+ $(INSTALL_DIR) $(1)/usr/include
|
|
54
|
+ $(CP) \
|
|
55
|
+ $(PKG_INSTALL_DIR)/usr/include/libnetfilter_cthelper \
|
|
56
|
+ $(1)/usr/include/
|
|
57
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
58
|
+ $(CP) \
|
|
59
|
+ $(PKG_INSTALL_DIR)/usr/lib/libnetfilter_cthelper*.{a,la,so*} \
|
|
60
|
+ $(1)/usr/lib/
|
|
61
|
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
|
62
|
+ $(CP) \
|
|
63
|
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnetfilter_cthelper.pc \
|
|
64
|
+ $(1)/usr/lib/pkgconfig/
|
|
65
|
+endef
|
|
66
|
+
|
|
67
|
+define Package/libnetfilter-cthelper/install
|
|
68
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
69
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnetfilter_cthelper*.so.* $(1)/usr/lib/
|
|
70
|
+endef
|
|
71
|
+
|
|
72
|
+$(eval $(call BuildPackage,libnetfilter-cthelper))
|