|
@@ -0,0 +1,75 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=libradcli
|
|
11
|
+PKG_VERSION:=1.2.1
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=radcli-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=https://github.com/radcli/radcli/releases/download/radcli_1_2_1/
|
|
16
|
+PKG_MD5SUM:=48f917ed3822ed2d91a5e90309a80812
|
|
17
|
+PKG_BUILD_DIR:=$(BUILD_DIR)/radcli-$(PKG_VERSION)
|
|
18
|
+
|
|
19
|
+PKG_INSTALL:=1
|
|
20
|
+
|
|
21
|
+include $(INCLUDE_DIR)/package.mk
|
|
22
|
+
|
|
23
|
+define Package/libradcli
|
|
24
|
+ SECTION:=libs
|
|
25
|
+ CATEGORY:=Libraries
|
|
26
|
+ TITLE:=A library for radius clients
|
|
27
|
+ URL:=http://radcli.github.io/radcli/
|
|
28
|
+ MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
|
|
29
|
+ DEPENDS:= +RADCLI_TLS:libgnutls +libnettle
|
|
30
|
+endef
|
|
31
|
+
|
|
32
|
+define Package/libradcli/decription
|
|
33
|
+ The radcli library is a library for writing RADIUS Clients. The library's
|
|
34
|
+ approach is to allow writing RADIUS-aware application in less than 50 lines
|
|
35
|
+ of C code. It was based originally on freeradius-client and is source
|
|
36
|
+ compatible with it.
|
|
37
|
+endef
|
|
38
|
+
|
|
39
|
+CONFIGURE_ARGS+= \
|
|
40
|
+ --enable-legacy-compat
|
|
41
|
+
|
|
42
|
+ifneq ($(CONFIG_RADCLI_TLS),y)
|
|
43
|
+CONFIGURE_ARGS += --without-tls
|
|
44
|
+endif
|
|
45
|
+
|
|
46
|
+define Build/InstallDev
|
|
47
|
+ $(INSTALL_DIR) $(1)/usr/include/radcli
|
|
48
|
+ $(CP) \
|
|
49
|
+ $(PKG_INSTALL_DIR)/usr/include/radcli/radcli.h \
|
|
50
|
+ $(PKG_INSTALL_DIR)/usr/include/radcli/version.h \
|
|
51
|
+ $(1)/usr/include/radcli
|
|
52
|
+ $(CP) \
|
|
53
|
+ $(PKG_INSTALL_DIR)/usr/include/freeradius-client.h \
|
|
54
|
+ $(1)/usr/include/
|
|
55
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
56
|
+ $(CP) \
|
|
57
|
+ $(PKG_INSTALL_DIR)/usr/lib/libradcli.so* \
|
|
58
|
+ $(PKG_INSTALL_DIR)/usr/lib/libfreeradius-client.so \
|
|
59
|
+ $(1)/usr/lib/
|
|
60
|
+endef
|
|
61
|
+
|
|
62
|
+define Package/libradcli/conffiles
|
|
63
|
+/etc/radcli/radiusclient.conf
|
|
64
|
+endef
|
|
65
|
+
|
|
66
|
+define Package/libradcli/install
|
|
67
|
+ $(INSTALL_DIR) $(1)/etc/radcli
|
|
68
|
+ $(INSTALL_CONF) $(PKG_BUILD_DIR)/etc/radiusclient.conf $(1)/etc/radcli/
|
|
69
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
70
|
+ $(CP) \
|
|
71
|
+ $(PKG_INSTALL_DIR)/usr/lib/libradcli.so.* \
|
|
72
|
+ $(1)/usr/lib/
|
|
73
|
+endef
|
|
74
|
+
|
|
75
|
+$(eval $(call BuildPackage,libradcli))
|