Browse Source

pcre: Integrate pending patches for next upstream version 8.39

 - Fix auto-callout
    (http://vcs.pcre.org/viewvc?view=rev&revision=1611)
 -  Fix negated POSIX class within negated overall class UCP
    (git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1612 2f5784b3-3f2a-0410-8824-cb99058d5e)
 - Fix bug for isolated \E between an item and its qualifier when auto callout is set.
    (git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1613 2f5784b3-3f2a-0410-8824-cb99058d5e)
 - Give error for regexec with pmatch=NULL and REG_STARTEND set
    (git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1614 2f5784b3-3f2a-0410-8824-cb99058d5e)
 - Fix \Q\E before qualifier bug when auto callouts are
   (git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1616 2f5784b3-3f2a-0410-8824-cb99058d5e)
 - Fix /x bug when pattern starts with white space and (?-x)
   (git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1617 2f5784b3-3f2a-0410-8824-cb99058d5e)
 - Fix copy named substring bug.
   (git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1618 2f5784b3-3f2a-0410-8824-cb99058d5e)
 - Fix (by hacking) another length computation issue.
   (git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1619 2f5784b3-3f2a-0410-8824-cb99058d5e

 - Fix get_substring_list() bug when \K is used in an assertion.
   (git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1620 2f5784b3-3f2a-0410-8824-cb99058d5e

 - Fix pcretest bad behaviour for callout in lookbehind.
   (git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1625 2f5784b3-3f2a-0410-8824-cb99058d5e

 - Fix workspace overflow for (*ACCEPT) with deeply nested
   (git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1631 2f5784b3-3f2a-0410-8824-cb99058d5e
   fixes CVE-2016-3191

 - Fix Yet another duplicate name bugfix by overestimating the memory needed (i.e. another hack - PCRE2 has this "properly" fixed).
   (git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1636 2f5784b3-3f2a-0410-8824-cb99058d5e

 - Fix pcretest loop for global matching with an ovector size
   (git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1637 2f5784b3-3f2a-0410-8824-cb99058d5e

Signed-off-by: heil <heil@terminal-consulting.de>
heil 9 years ago
parent
commit
cb6418bec4
2 changed files with 1409 additions and 1 deletions
  1. 1
    1
      libs/pcre/Makefile
  2. 1408
    0
      libs/pcre/patches/001-pcre-8.38-upstream_fixes-1.patch

+ 1
- 1
libs/pcre/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=pcre
11 11
 PKG_VERSION:=8.38
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15 15
 PKG_SOURCE_URL:=ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/

+ 1408
- 0
libs/pcre/patches/001-pcre-8.38-upstream_fixes-1.patch
File diff suppressed because it is too large
View File