浏览代码

dmidecode: Import 2.12 from packages.

Álvaro Fernández Rojas 10 年前
父节点
当前提交
cb891adebd
共有 1 个文件被更改,包括 45 次插入0 次删除
  1. 45
    0
      utils/dmidecode/Makefile

+ 45
- 0
utils/dmidecode/Makefile 查看文件

@@ -0,0 +1,45 @@
1
+#
2
+# Copyright (C) 2007-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=dmidecode
11
+PKG_VERSION:=2.12
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15
+PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/dmidecode
16
+PKG_MD5SUM:=a406f3cbb27736491698697beeddb781
17
+PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
18
+
19
+PKG_INSTALL:=1
20
+
21
+include $(INCLUDE_DIR)/package.mk
22
+
23
+define Package/dmidecode
24
+  SECTION:=utils
25
+  CATEGORY:=Utilities
26
+  DEPENDS:=@(TARGET_x86||TARGET_x86_64)
27
+  TITLE:=Displays BIOS informations.
28
+  URL:=http://www.nongnu.org/dmidecode/
29
+endef
30
+
31
+define Package/dmidecode/description
32
+	Dmidecode reports information about your system's hardware
33
+	as described in your system BIOS according to the SMBIOS/DMI
34
+	standard.
35
+endef
36
+
37
+MAKE_FLAGS += \
38
+	prefix="/usr"
39
+
40
+define Package/dmidecode/install
41
+	$(INSTALL_DIR) $(1)/usr/sbin
42
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/$(PKG_NAME) $(1)/usr/sbin/
43
+endef
44
+
45
+$(eval $(call BuildPackage,dmidecode))