|
@@ -0,0 +1,117 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2009-2011 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=prosody
|
|
11
|
+PKG_VERSION:=0.9.4
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=http://prosody.im/downloads/source
|
|
16
|
+PKG_MD5SUM:=94f9a613c834c276352ac5b142fb72e0
|
|
17
|
+PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
|
|
18
|
+PKG_LICENSE:=MIT/X11
|
|
19
|
+
|
|
20
|
+PKG_INSTALL:=1
|
|
21
|
+
|
|
22
|
+include $(INCLUDE_DIR)/package.mk
|
|
23
|
+
|
|
24
|
+define Package/prosody
|
|
25
|
+ SECTION:=net
|
|
26
|
+ CATEGORY:=Network
|
|
27
|
+ SUBMENU:=Instant Messaging
|
|
28
|
+ DEPENDS:=+luafilesystem +libidn +luaexpat +luasec +libopenssl +libidn +liblua
|
|
29
|
+ TITLE:=XMPP server
|
|
30
|
+ URL:=http://prosody.im/
|
|
31
|
+endef
|
|
32
|
+
|
|
33
|
+define Package/prosody/description
|
|
34
|
+ Prosody is an exciting new server for Jabber/XMPP
|
|
35
|
+ written in Lua. It aims to be easy to use, and light
|
|
36
|
+ on resources
|
|
37
|
+endef
|
|
38
|
+
|
|
39
|
+define Package/prosody/conffiles
|
|
40
|
+/etc/prosody/prosody.cfg.lua
|
|
41
|
+endef
|
|
42
|
+
|
|
43
|
+TARGET_CFLAGS += $(FPIC)
|
|
44
|
+
|
|
45
|
+TARGET_LDFLAGS += -L$(STAGING_DIR)/usr/lib
|
|
46
|
+
|
|
47
|
+
|
|
48
|
+define Build/Configure
|
|
49
|
+ # this is *NOT* GNU autoconf stuff
|
|
50
|
+ (cd $(PKG_BUILD_DIR); ./configure \
|
|
51
|
+ --prefix=/usr \
|
|
52
|
+ --with-lua="$(STAGING_DIR)/host/bin" \
|
|
53
|
+ --with-lua-include="$(STAGING_DIR)/usr/include" \
|
|
54
|
+ --with-lua-lib="$(STAGING_DIR)/usr/lib" \
|
|
55
|
+ --cflags="$(TARGET_CFLAGS)" \
|
|
56
|
+ --ldflags="$(TARGET_LDFLAGS) -llua -lm -ldl -shared" \
|
|
57
|
+ --c-compiler="$(CC)" \
|
|
58
|
+ --linker="$(LD)" \
|
|
59
|
+ --datadir="/etc/prosody/data" \
|
|
60
|
+ )
|
|
61
|
+endef
|
|
62
|
+# LDFLAGS="$(TARGET_LDFLAGS) -llua -lm -ldl" \
|
|
63
|
+
|
|
64
|
+MAKE_FLAGS += \
|
|
65
|
+ CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -std=gnu99" \
|
|
66
|
+ PREFIX="/usr" \
|
|
67
|
+
|
|
68
|
+define Package/prosody/install
|
|
69
|
+ $(INSTALL_DIR) $(1)/etc/init.d
|
|
70
|
+ $(INSTALL_BIN) ./files/prosody.init $(1)/etc/init.d/prosody
|
|
71
|
+ $(INSTALL_DIR) $(1)/etc/prosody
|
|
72
|
+ #$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/prosody/prosody.cfg.lua $(1)/etc/prosody/
|
|
73
|
+ $(INSTALL_CONF) ./files/prosody.cfg.lua $(1)/etc/prosody/
|
|
74
|
+ $(INSTALL_DIR) $(1)/etc/prosody/certs
|
|
75
|
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/prosody/certs/localhost.{crt,key} $(1)/etc/prosody/certs/
|
|
76
|
+ $(INSTALL_DIR) $(1)/etc/prosody/data
|
|
77
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
78
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/prosody{,ctl} $(1)/usr/bin/
|
|
79
|
+ $(INSTALL_DIR) $(1)/usr/lib/prosody
|
|
80
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/prosody/prosody.version $(1)/usr/lib/prosody/
|
|
81
|
+ $(INSTALL_DIR) $(1)/usr/lib/prosody/core
|
|
82
|
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/core/*.lua $(1)/usr/lib/prosody/core/
|
|
83
|
+ $(INSTALL_DIR) $(1)/usr/lib/prosody/fallbacks
|
|
84
|
+ #$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/fallbacks/*.lua $(1)/usr/lib/prosody/fallbacks/
|
|
85
|
+ $(INSTALL_DIR) $(1)/usr/lib/prosody/modules
|
|
86
|
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/modules/*.lua $(1)/usr/lib/prosody/modules/
|
|
87
|
+ $(INSTALL_DIR) $(1)/usr/lib/prosody/modules/muc
|
|
88
|
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/modules/muc/*.lua $(1)/usr/lib/prosody/modules/muc/
|
|
89
|
+ $(INSTALL_DIR) $(1)/usr/lib/prosody/net
|
|
90
|
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/net/*.lua $(1)/usr/lib/prosody/net/
|
|
91
|
+ $(INSTALL_DIR) $(1)/usr/lib/prosody/net/http
|
|
92
|
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/net/http/*.lua $(1)/usr/lib/prosody/net/http/
|
|
93
|
+ $(INSTALL_DIR) $(1)/usr/lib/prosody/util
|
|
94
|
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/*.lua $(1)/usr/lib/prosody/util/
|
|
95
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/*.so $(1)/usr/lib/prosody/util/
|
|
96
|
+ $(INSTALL_DIR) $(1)/usr/lib/prosody/util/sasl
|
|
97
|
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/sasl/*.lua $(1)/usr/lib/prosody/util/sasl/
|
|
98
|
+ #$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/sasl/*.so $(1)/usr/lib/prosody/util/sasl/
|
|
99
|
+endef
|
|
100
|
+
|
|
101
|
+define Package/prosody/postinst
|
|
102
|
+#!/bin/sh
|
|
103
|
+[ -n "$${IPKG_INSTROOT}" ] || {
|
|
104
|
+ echo "Fixing lua with paxctl if needed!!!"
|
|
105
|
+ [ -f /sbin/paxctl ] && {
|
|
106
|
+ paxctl -v /usr/bin/ > /dev/null 2>&1
|
|
107
|
+ [ $$? -ne 0 ] && {
|
|
108
|
+ cp /usr/bin/lua /tmp
|
|
109
|
+ paxctl -c -m /tmp/lua > /dev/null 2>&1
|
|
110
|
+ cp -f /tmp/lua /usr/bin/lua
|
|
111
|
+ }
|
|
112
|
+ }
|
|
113
|
+ exit 0
|
|
114
|
+}
|
|
115
|
+endef
|
|
116
|
+
|
|
117
|
+$(eval $(call BuildPackage,prosody))
|