|
@@ -0,0 +1,64 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=perl-parse-recdescent
|
|
11
|
+PKG_VERSION:=1.967009
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/J/JT/JTBRAUN
|
|
15
|
+PKG_SOURCE:=Parse-RecDescent-$(PKG_VERSION).tar.gz
|
|
16
|
+PKG_MD5SUM:=6dab60d44451a9f57a261d1b5358753c
|
|
17
|
+
|
|
18
|
+PKG_LICENSE:=GPL-1.0+ Artistic-1.0-Perl
|
|
19
|
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
|
|
20
|
+
|
|
21
|
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/perl/Parse-RecDescent-$(PKG_VERSION)
|
|
22
|
+HOST_BUILD_DEPENDS:=perl/host
|
|
23
|
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/Parse-RecDescent-$(PKG_VERSION)
|
|
24
|
+
|
|
25
|
+include $(INCLUDE_DIR)/package.mk
|
|
26
|
+include $(INCLUDE_DIR)/host-build.mk
|
|
27
|
+include ../perl/perlmod.mk
|
|
28
|
+
|
|
29
|
+define Package/perl-parse-recdescent
|
|
30
|
+ SUBMENU:=Perl
|
|
31
|
+ SECTION:=lang
|
|
32
|
+ CATEGORY:=Languages
|
|
33
|
+ TITLE:=Generate Recursive-Descent Parsers
|
|
34
|
+ URL:=http://search.cpan.org/dist/Parse-RecDescent/
|
|
35
|
+ DEPENDS:=perl +perlbase-essential +perlbase-test +perlbase-text
|
|
36
|
+endef
|
|
37
|
+
|
|
38
|
+define Host/Configure
|
|
39
|
+ $(call perlmod/host/Configure,,,)
|
|
40
|
+endef
|
|
41
|
+
|
|
42
|
+define Host/Compile
|
|
43
|
+ $(call perlmod/host/Compile,,)
|
|
44
|
+endef
|
|
45
|
+
|
|
46
|
+define Host/Install
|
|
47
|
+ $(call perlmod/host/Install,$(1),)
|
|
48
|
+endef
|
|
49
|
+
|
|
50
|
+define Build/Configure
|
|
51
|
+ $(call perlmod/Configure,,)
|
|
52
|
+endef
|
|
53
|
+
|
|
54
|
+define Build/Compile
|
|
55
|
+ $(call perlmod/Compile,,)
|
|
56
|
+endef
|
|
57
|
+
|
|
58
|
+define Package/perl-parse-recdescent/install
|
|
59
|
+ $(call perlmod/Install,$(1),Parse auto/Parse)
|
|
60
|
+endef
|
|
61
|
+
|
|
62
|
+
|
|
63
|
+$(eval $(call BuildPackage,perl-parse-recdescent))
|
|
64
|
+$(eval $(call HostBuild))
|