Browse Source

dump1090: switch to mutability repo, make view1090 a separate package

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Álvaro Fernández Rojas 9 years ago
parent
commit
cf18ddf0a2

+ 0
- 20
utils/dump1090/Config.in View File

@@ -1,20 +0,0 @@
1
-config DUMP1090_DUMP
2
-	bool "dump1090"
3
-	depends on PACKAGE_dump1090
4
-	default y
5
-	help
6
-		dump1090 ModeS Receiver
7
-
8
-config DUMP1090_WWW
9
-	bool "website files"
10
-	depends on DUMP1090_DUMP
11
-	default y
12
-	help
13
-		HTML website files for showing planes
14
-
15
-config DUMP1090_VIEW
16
-	bool "view1090"
17
-	depends on PACKAGE_dump1090
18
-	default n
19
-	help
20
-		view1090 dump1090 Viewer

+ 27
- 25
utils/dump1090/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2013-2014 OpenWrt.org
2
+# Copyright (C) 2013-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,63 +8,65 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=dump1090
11
-PKG_VERSION:=2014-11-09
11
+PKG_VERSION:=2015-09-28
12 12
 PKG_RELEASE:=$(PKG_SOURCE_VERSION)
13 13
 
14 14
 PKG_SOURCE_PROTO:=git
15
-PKG_SOURCE_URL:=git://github.com/MalcolmRobb/dump1090.git
15
+PKG_SOURCE_URL:=git://github.com/mutability/dump1090.git
16 16
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
17
-PKG_SOURCE_VERSION:=bff92c4ad772a0a8d433f788d39dae97e00e4dbe
17
+PKG_SOURCE_VERSION:=3b4c872ea67118de1399ba9979e71b504a36aca8
18 18
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
19 19
 PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
20 20
 
21
-PKG_LICENSE:=BSD-3c
22
-
23
-PKG_CONFIG_DEPENDS:= \
24
-	CONFIG_DUMP1090_DUMP \
25
-	CONFIG_DUMP1090_WWW \
26
-	CONFIG_DUMP1090_VIEW
21
+PKG_LICENSE:=GPL-2.0
22
+PKG_LICENSE_FILES:=COPYING,LICENSE
27 23
 
28 24
 include $(INCLUDE_DIR)/package.mk
29 25
 
30
-define Package/dump1090
26
+define Package/dump1090/Default
31 27
   SECTION:=utils
32 28
   CATEGORY:=Utilities
33 29
   TITLE:=Mode S decoder for the Realtek RTL2832U
34
-  URL:=https://github.com/MalcolmRobb/dump1090
30
+  URL:=https://github.com/mutability/dump1090
35 31
   DEPENDS:=+libpthread +librtlsdr
36 32
 endef
37 33
 
38
-define Package/dump1090/config
39
-	source "$(SOURCE)/Config.in"
34
+define Package/dump1090
35
+  $(call Package/dump1090/Default)
36
+  TITLE+= (dump1090)
37
+endef
38
+
39
+define Package/view1090
40
+  $(call Package/dump1090/Default)
41
+  TITLE+= (view1090)
40 42
 endef
41 43
 
42 44
 define Package/dump1090/description
43 45
  Dump1090 is a Mode S decoder specifically designed for RTLSDR devices.
44
- Embedded HTTP server that displays the currently detected aircrafts on
45
- Google Maps. Network output in Basestation and AVR formats.
46
+endef
47
+
48
+define Package/view1090/description
49
+ View1090 is a Mode S messages viewer for dump1090 devices.
46 50
 endef
47 51
 
48 52
 MAKE_FLAGS += \
49 53
 	CFLAGS="$(TARGET_CFLAGS)"
50 54
 
51 55
 define Package/dump1090/install
52
-	$(INSTALL_DIR) $(1)/usr/bin
53
-
54
-ifneq ($(CONFIG_DUMP1090_DUMP),)
55 56
 	$(INSTALL_DIR) $(1)/etc/init.d
56 57
 	$(INSTALL_BIN) files/dump1090.init $(1)/etc/init.d/dump1090
57 58
 	$(INSTALL_DIR) $(1)/etc/config
58 59
 	$(INSTALL_CONF) files/dump1090.config $(1)/etc/config/dump1090
59
-	$(INSTALL_BIN) $(PKG_BUILD_DIR)/dump1090 $(1)/usr/bin
60
-ifneq ($(CONFIG_DUMP1090_WWW),)
61 60
 	$(INSTALL_DIR) $(1)/usr/share/dump1090
62 61
 	$(CP) $(PKG_BUILD_DIR)/public_html/* $(1)/usr/share/dump1090
63
-endif
64
-endif
65
-ifneq ($(CONFIG_DUMP1090_VIEW),)
62
+	$(INSTALL_DIR) $(1)/usr/bin
63
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/dump1090 $(1)/usr/bin
64
+endef
65
+
66
+define Package/view1090/install
67
+	$(INSTALL_DIR) $(1)/usr/bin
66 68
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/view1090 $(1)/usr/bin
67
-endif
68 69
 endef
69 70
 
70 71
 $(eval $(call BuildPackage,dump1090))
72
+$(eval $(call BuildPackage,view1090))

+ 15
- 1
utils/dump1090/files/dump1090.config View File

@@ -6,6 +6,8 @@ config dump1090 main
6 6
 	option enable_agc '0'
7 7
 	option freq ''
8 8
 	option ifile ''
9
+	option iformat ''
10
+	option throttle '0'
9 11
 	option raw '0'
10 12
 	option net '1'
11 13
 	option modeac '0'
@@ -18,12 +20,16 @@ config dump1090 main
18 20
 	option net_sbs_port ''
19 21
 	option net_bi_port ''
20 22
 	option net_bo_port ''
23
+	option net_fatsv_port ''
21 24
 	option net_ro_size ''
22
-	option net_ro_rate ''
25
+	option net_ro_interval ''
23 26
 	option net_heartbeat ''
24 27
 	option net_buffer ''
28
+	option net_verbatim '0'
29
+	option forward_mlat '0'
25 30
 	option lat ''
26 31
 	option lon ''
32
+	option max_range ''
27 33
 	option fix '0'
28 34
 	option no_fix '0'
29 35
 	option no_crc_check '0'
@@ -31,9 +37,17 @@ config dump1090 main
31 37
 	option agressive '0'
32 38
 	option mlat '0'
33 39
 	option stats '0'
40
+	option stats_range '0'
34 41
 	option stats_every ''
35 42
 	option onlyaddr '0'
36 43
 	option metric '0'
37 44
 	option snip ''
38 45
 	option debug ''
39 46
 	option ppm ''
47
+	option html_dir '/usr/share/dump1090'
48
+	option write_json ''
49
+	option write_json_every ''
50
+	option json_location_accuracy ''
51
+	option oversample '0'
52
+	option dcfilter '0'
53
+	option measure_noise '0'

+ 16
- 2
utils/dump1090/files/dump1090.init View File

@@ -1,5 +1,5 @@
1 1
 #!/bin/sh /etc/rc.common
2
-# Copyright (C) 2014 OpenWrt.org
2
+# Copyright (C) 2014-2015 OpenWrt.org
3 3
 
4 4
 START=90
5 5
 STOP=10
@@ -44,6 +44,8 @@ start_instance() {
44 44
 	append_bool "$cfg" enable_agc "--enable-agc"
45 45
 	append_arg "$cfg" freq "--freq"
46 46
 	append_arg "$cfg" ifile "--ifile"
47
+	append_arg "$cfg" iformat "--iformat"
48
+	append_bool "$cfg" throttle "--throttle"
47 49
 	append_bool "$cfg" raw "--raw"
48 50
 	append_bool "$cfg" net "--net"
49 51
 	append_bool "$cfg" modeac "--modeac"
@@ -56,12 +58,16 @@ start_instance() {
56 58
 	append_arg "$cfg" net_sbs_port "--net-sbs-port"
57 59
 	append_arg "$cfg" net_bi_port "--net-bi-port"
58 60
 	append_arg "$cfg" net_bo_port "--net-bo-port"
61
+	append_arg "$cfg" net_fatsv_port "net-fatsv-port"
59 62
 	append_arg "$cfg" net_ro_size "--net-ro-size"
60
-	append_arg "$cfg" net_ro_rate "--net-ro-rate"
63
+	append_arg "$cfg" net_ro_interval "--net-ro-interval"
61 64
 	append_arg "$cfg" net_heartbeat "--net-heartbeat"
62 65
 	append_arg "$cfg" net_buffer "--net-buffer"
66
+	append_bool "$cfg" net_verbatim "--net-verbatim"
67
+	append_bool "$cfg" forward_mlat "--forward-mlat"
63 68
 	append_arg "$cfg" lat "--lat"
64 69
 	append_arg "$cfg" lon "--lon"
70
+	append_arg "$cfg" max_range "--max-range"
65 71
 	append_bool "$cfg" fix "--fix"
66 72
 	append_bool "$cfg" no_fix "--no-fix"
67 73
 	append_bool "$cfg" no_crc_check "--no-crc-check"
@@ -69,12 +75,20 @@ start_instance() {
69 75
 	append_bool "$cfg" agressive "--agressive"
70 76
 	append_bool "$cfg" mlat "--mlat"
71 77
 	append_bool "$cfg" stats "--stats"
78
+	append_bool "$cfg" stats_range "--stats-range"
72 79
 	append_arg "$cfg" stats_every "--stats-every"
73 80
 	append_bool "$cfg" onlyaddr "--onlyaddr"
74 81
 	append_bool "$cfg" metric "--metric"
75 82
 	append_arg "$cfg" snip "--snip"
76 83
 	append_arg "$cfg" debug "--debug"
77 84
 	append_arg "$cfg" ppm "--ppm"
85
+	append_arg "$cfg" html_dir "--html-dir"
86
+	append_arg "$cfg" write_json "--write-json"
87
+	append_arg "$cfg" write_json_every "write-json-every"
88
+	append_arg "$cfg" json_location_accuracy "--json-location-accuracy"
89
+	append_bool "$cfg" oversample "--oversample"
90
+	append_bool "$cfg" dcfilter "--dcfilter"
91
+	append_bool "$cfg" measure_noise "--measure-noise"
78 92
 
79 93
 	config_get_bool aux "$cfg" 'respawn' '0'
80 94
 	[ "$aux" = 1 ] && procd_set_param respawn

+ 0
- 11
utils/dump1090/patches/100-html_dir.patch View File

@@ -1,11 +0,0 @@
1
---- a/dump1090.h
2
-+++ b/dump1090.h
3
-@@ -178,7 +178,7 @@
4
- #define MODES_NET_SNDBUF_MAX  (7)               
5
- 
6
- #ifndef HTMLPATH
7
--#define HTMLPATH   "./public_html"      // default path for gmap.html etc
8
-+#define HTMLPATH   "/usr/share/dump1090"      // default path for gmap.html etc
9
- #endif
10
- 
11
- #define MODES_NOTUSED(V) ((void) V)