Browse Source

python: add patch to disable package compiles/tests during cross-builts

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean 10 years ago
parent
commit
d05c846e69
1 changed files with 37 additions and 0 deletions
  1. 37
    0
      lang/python/patches/130-do-not-run-distutils-tests.patch

+ 37
- 0
lang/python/patches/130-do-not-run-distutils-tests.patch View File

@@ -0,0 +1,37 @@
1
+diff --git a/Makefile.pre.in b/Makefile.pre.in
2
+index bcd83bf..c4dcc6d 100644
3
+--- a/Makefile.pre.in
4
++++ b/Makefile.pre.in
5
+@@ -1005,32 +1005,6 @@ libinstall:	build_all $(srcdir)/Lib/$(PLATDIR) $(srcdir)/Modules/xxmodule.c
6
+ 		done; \
7
+ 	done
8
+ 	$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
9
+-	if test -d $(DESTDIR)$(LIBDEST)/distutils/tests; then \
10
+-		$(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
11
+-			$(DESTDIR)$(LIBDEST)/distutils/tests ; \
12
+-	fi
13
+-	PYTHONPATH=$(DESTDIR)$(LIBDEST)  $(RUNSHARED) \
14
+-		$(PYTHON_FOR_BUILD) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
15
+-		-d $(LIBDEST) -f \
16
+-		-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
17
+-		$(DESTDIR)$(LIBDEST)
18
+-	PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
19
+-		$(PYTHON_FOR_BUILD) -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
20
+-		-d $(LIBDEST) -f \
21
+-		-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
22
+-		$(DESTDIR)$(LIBDEST)
23
+-	-PYTHONPATH=$(DESTDIR)$(LIBDEST)  $(RUNSHARED) \
24
+-		$(PYTHON_FOR_BUILD) -Wi -t $(DESTDIR)$(LIBDEST)/compileall.py \
25
+-		-d $(LIBDEST)/site-packages -f \
26
+-		-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
27
+-	-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
28
+-		$(PYTHON_FOR_BUILD) -Wi -t -O $(DESTDIR)$(LIBDEST)/compileall.py \
29
+-		-d $(LIBDEST)/site-packages -f \
30
+-		-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
31
+-	-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
32
+-		$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt
33
+-	-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
34
+-		$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
35
+ 
36
+ # Create the PLATDIR source directory, if one wasn't distributed..
37
+ $(srcdir)/Lib/$(PLATDIR):