Browse Source

shairport-sync: Add "mini" package (no soxr, no avahi, use polarssl)

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 9 years ago
parent
commit
d1dda2700a
1 changed files with 44 additions and 21 deletions
  1. 44
    21
      sound/shairport-sync/Makefile

+ 44
- 21
sound/shairport-sync/Makefile View File

@@ -10,14 +10,15 @@ include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=shairport-sync
12 12
 PKG_VERSION:=2.6
13
-PKG_RELEASE:=1
13
+PKG_RELEASE:=2
14 14
 
15 15
 PKG_SOURCE_PROTO:=git
16 16
 PKG_SOURCE_URL:=git://github.com/mikebrady/shairport-sync.git
17 17
 PKG_SOURCE_VERSION:=$(PKG_VERSION)
18 18
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
19 19
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
20
-PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, Mike Brady <mikebrady@eircom.net>
20
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
21
+		Mike Brady <mikebrady@eircom.net>
21 22
 
22 23
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_SOURCE_SUBDIR)
23 24
 
@@ -29,49 +30,42 @@ PKG_FIXUP:=autoreconf
29 30
 
30 31
 include $(INCLUDE_DIR)/package.mk
31 32
 
32
-CONFIGURE_ARGS+= \
33
-	--with-alsa \
34
-	--with-avahi \
35
-	--with-soxr \
36
-	--with-metadata
37
-
38
-ifeq ($(BUILD_VARIANT),openssl)
39
-  CONFIGURE_ARGS+= --with-ssl=openssl
40
-endif
41
-ifeq ($(BUILD_VARIANT),polarssl)
42
-  CONFIGURE_ARGS+= --with-ssl=polarssl
43
-endif
44
-
45 33
 define Package/shairport-sync/default
46 34
   SECTION:=sound
47 35
   CATEGORY:=Sound
48
-  TITLE:=iPhone/iTunes/AirPlay/Quicktime Player compatible Audio Player
49
-  DEPENDS:=@AUDIO_SUPPORT +libpthread +libavahi-client +alsa-lib +libconfig +libdaemon +libsoxr +libpopt
36
+  TITLE:=AirPlay compatible audio player
37
+  DEPENDS:=@AUDIO_SUPPORT +libpthread +alsa-lib +libconfig +libdaemon +libpopt
50 38
   URL:=http://github.com/mikebrady/shairport-sync
51 39
 endef
52 40
 
53 41
 define Package/shairport-sync-openssl
54 42
   $(Package/shairport-sync/default)
55 43
   TITLE+= (openssl)
56
-  DEPENDS+= +PACKAGE_shairport-sync-openssl:libopenssl
44
+  DEPENDS+= +PACKAGE_shairport-sync-openssl:libopenssl +libavahi-client +libsoxr
57 45
   VARIANT:=openssl
58 46
 endef
59 47
 
60 48
 define Package/shairport-sync-polarssl
61 49
   $(Package/shairport-sync/default)
62 50
   TITLE+= (polarssl)
63
-  DEPENDS+= +PACKAGE_shairport-sync-polarssl:libpolarssl
51
+  DEPENDS+= +PACKAGE_shairport-sync-polarssl:libpolarssl +libavahi-client +libsoxr
64 52
   VARIANT:=polarssl
65 53
   DEFAULT_VARIANT:=1
66 54
 endef
67 55
 
56
+define Package/shairport-sync-mini
57
+  $(Package/shairport-sync/default)
58
+  TITLE+= (minimal)
59
+  DEPENDS+= +libpolarssl
60
+  VARIANT:=mini
61
+endef
62
+
68 63
 define Package/shairport-sync/default/description
69 64
   Shairport Sync plays audio from iTunes and AirPlay sources, including
70 65
   iOS devices, Quicktime Player and third party sources such as forkedDaapd.
71 66
   Audio played by a Shairport Sync-powered device stays synchronised with the source
72 67
   and hence with similar devices playing the same source.
73
-  Thus, for example, synchronised multi-room audio is possible without difficulty.
74
-  (Hence the name Shairport Sync, BTW.)
68
+
75 69
   Shairport Sync does not support AirPlay video or photo streaming.
76 70
   Ensure Kernel Modules > Sound Support > kmod-sound-core is selected.
77 71
   Also select kmod-usb-audio if you want to use USB-connected sound cards.
@@ -79,11 +73,37 @@ endef
79 73
 Package/shairport-sync-openssl/description = $(Package/shairport-sync/default/description)
80 74
 Package/shairport-sync-polarssl/description = $(Package/shairport-sync/default/description)
81 75
 
76
+define Package/shairport-sync-mini/description
77
+  $(Package/shairport-sync/default/description)
78
+
79
+  Minimal version uses PolarSSL and does not include libsoxr and avahi support.
80
+endef
81
+
82
+CONFIGURE_ARGS+= \
83
+	--with-alsa \
84
+	--with-metadata
85
+
86
+ifeq ($(BUILD_VARIANT),openssl)
87
+  CONFIGURE_ARGS+= --with-ssl=openssl
88
+endif
89
+
90
+ifeq ($(BUILD_VARIANT),polarssl)
91
+  CONFIGURE_ARGS+= --with-ssl=polarssl
92
+endif
93
+
94
+ifeq ($(BUILD_VARIANT),mini)
95
+  CONFIGURE_ARGS+= --with-ssl=polarssl --with-tinysvcmdns
96
+else
97
+  CONFIGURE_ARGS+= --with-avahi --with-soxr
98
+endif
99
+
82 100
 define Package/shairport-sync/default/conffiles
83 101
 /etc/shairport-sync.conf
84 102
 endef
103
+
85 104
 Package/shairport-sync-openssl/conffiles = $(Package/shairport-sync/default/conffiles)
86 105
 Package/shairport-sync-polarssl/conffiles = $(Package/shairport-sync/default/conffiles)
106
+Package/shairport-sync-mini/conffiles = $(Package/shairport-sync/default/conffiles)
87 107
 
88 108
 define Package/shairport-sync/default/install
89 109
 	$(INSTALL_DIR) $(1)/usr/bin
@@ -95,8 +115,11 @@ define Package/shairport-sync/default/install
95 115
 	$(INSTALL_DIR) $(1)/etc/config
96 116
 	$(INSTALL_DATA) ./files/shairport-sync.config $(1)/etc/config/shairport-sync
97 117
 endef
118
+
98 119
 Package/shairport-sync-openssl/install = $(Package/shairport-sync/default/install)
99 120
 Package/shairport-sync-polarssl/install = $(Package/shairport-sync/default/install)
121
+Package/shairport-sync-mini/install = $(Package/shairport-sync/default/install)
100 122
 
101 123
 $(eval $(call BuildPackage,shairport-sync-openssl))
102 124
 $(eval $(call BuildPackage,shairport-sync-polarssl))
125
+$(eval $(call BuildPackage,shairport-sync-mini))