Browse Source

Merge pull request #1812 from MikePetullo/grilo

grilo: add new package
Steven Barth 9 years ago
parent
commit
d2ed4fab64
1 changed files with 68 additions and 0 deletions
  1. 68
    0
      multimedia/grilo/Makefile

+ 68
- 0
multimedia/grilo/Makefile View File

@@ -0,0 +1,68 @@
1
+#
2
+# Copyright (C) 2009-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=grilo
11
+PKG_VERSION:=0.2.14
12
+PKG_RELEASE:=1
13
+
14
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15
+
16
+PKG_LICENSE:=LGPLv2.1
17
+PKG_LICENSE_FILES:=COPYING
18
+
19
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
20
+PKG_SOURCE_URL:=https://download.gnome.org/sources/grilo/0.2/
21
+PKG_MD5SUM:=7eba405ada20fefcb877d534d9d4f
22
+
23
+PKG_BUILD_DEPENDS:=glib2 libsoup libxml2
24
+
25
+PKG_INSTALL:=1
26
+
27
+include $(INCLUDE_DIR)/package.mk
28
+include $(INCLUDE_DIR)/nls.mk
29
+
30
+TARGET_LDFLAGS+= \
31
+	-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
32
+
33
+define Package/grilo
34
+  SECTION:=multimedia
35
+  CATEGORY:=Multimedia
36
+  TITLE:=grilo
37
+  URL:=https://wiki.gnome.org/Projects/Grilo
38
+  DEPENDS:=+glib2 +libsoup +libxml2
39
+endef
40
+
41
+define Package/grilo/decription
42
+  Grilo is a framework that provides access to different sources of
43
+  multimedia content, using a pluggable system. 
44
+endef
45
+
46
+define Build/InstallDev
47
+	$(INSTALL_DIR) $(1)/usr/include/
48
+	$(CP) \
49
+		$(PKG_INSTALL_DIR)/usr/include/grilo-0.2/ \
50
+		$(1)/usr/include/
51
+	$(INSTALL_DIR) $(1)/usr/lib/
52
+	$(CP) \
53
+		$(PKG_INSTALL_DIR)/usr/lib/*.so* \
54
+		$(1)/usr/lib/
55
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
56
+	$(INSTALL_DATA) \
57
+		$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
58
+		$(1)/usr/lib/pkgconfig/
59
+endef
60
+
61
+define Package/grilo/install
62
+	$(INSTALL_DIR) $(1)/usr/lib/
63
+	$(CP) \
64
+		$(PKG_INSTALL_DIR)/usr/lib/*.so* \
65
+		$(1)/usr/lib/
66
+endef
67
+
68
+$(eval $(call BuildPackage,grilo))