Browse Source

Add exfat-nofuse: EXFAT filesystem kernel driver

Add "exfat-nofuse" kernel module for EXFAT filesystem which was originally
found in an Android kernel of Samsung. While there has been some doubt about
the license originally, it has later been officially released under the GPL by
Samsung and can be found on:
http://opensource.samsung.com/reception/receptionSub.do?method=sub&sub=F&searchValue=exfat

Signed-off-by: Bruno Randolf <br1@einfach.org>
Bruno Randolf 10 years ago
parent
commit
d2fef65165
1 changed files with 51 additions and 0 deletions
  1. 51
    0
      kernel/exfat-nofuse/Makefile

+ 51
- 0
kernel/exfat-nofuse/Makefile View File

@@ -0,0 +1,51 @@
1
+#
2
+# Copyright (C) 2014 Bruno Randolf <br1@einfach.org>
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+include $(INCLUDE_DIR)/kernel.mk
10
+
11
+PKG_NAME:=exfat-nofuse
12
+PKG_VERSION:=git-20150301
13
+PKG_RELEASE:=1
14
+
15
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
16
+PKG_SOURCE_URL:=https://github.com/dorimanx/exfat-nofuse.git
17
+PKG_SOURCE_PROTO:=git
18
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
19
+PKG_SOURCE_VERSION:=63964d3fb69cffe9a38822a657bb3b3279eebadf
20
+
21
+PKG_MAINTAINER:=Bruno Randolf <br1@einfach.org>
22
+PKG_LICENSE:=GPL-2.0
23
+PKG_LICENSE_FILES:=LICENSE
24
+
25
+include $(INCLUDE_DIR)/package.mk
26
+
27
+define KernelPackage/fs-exfat
28
+	SUBMENU:=Filesystems
29
+	TITLE:=ExFAT Kernel driver
30
+	FILES:=$(PKG_BUILD_DIR)/exfat.ko
31
+	AUTOLOAD:=$(call AutoLoad,30,exfat,1)
32
+	DEPENDS:=+kmod-nls-base
33
+endef
34
+
35
+define KernelPackage/fs-exfat/description
36
+	Kernel module for ExFAT Filesytems
37
+endef
38
+
39
+MAKE_OPTS:= \
40
+	ARCH="$(LINUX_KARCH)" \
41
+	CROSS_COMPILE="$(TARGET_CROSS)" \
42
+	M="$(PKG_BUILD_DIR)"
43
+
44
+define Build/Compile
45
+	$(MAKE) -C "$(LINUX_DIR)" \
46
+		$(MAKE_OPTS) \
47
+		CONFIG_EXFAT_FS=m \
48
+		modules
49
+endef
50
+
51
+$(eval $(call KernelPackage,fs-exfat))