Browse Source

mksh: SECURITY update to R50d

- new upstream version
- update my eMail address
- add maintainer and licence tag

Signed-off-by: Thorsten Glaser <tg@mirbsd.org>
Thorsten Glaser 10 years ago
parent
commit
d341cf9dcc
2 changed files with 19 additions and 11 deletions
  1. 13
    5
      utils/mksh/Makefile
  2. 6
    6
      utils/mksh/patches/100-dot_mkshrc

+ 13
- 5
utils/mksh/Makefile View File

@@ -1,6 +1,6 @@
1 1
 #
2 2
 # Copyright (C) 2007-2011 OpenWrt.org
3
-# Copyright (c) 2009-2013 Thorsten Glaser <tg@mirbsd.org>
3
+# Copyright (c) 2009-2014 Thorsten Glaser <tg@mirbsd.org>
4 4
 #
5 5
 # This is free software, licensed under the GNU General Public License v2.
6 6
 # See /LICENSE for more information.
@@ -9,12 +9,15 @@
9 9
 include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=mksh
12
-PKG_VERSION:=47
12
+PKG_VERSION:=50d
13 13
 PKG_RELEASE:=1
14 14
 
15
+PKG_MAINTAINER:=Thorsten Glaser <tg@mirbsd.org>
16
+PKG_LICENSE:=MirOS
17
+
15 18
 PKG_SOURCE:=$(PKG_NAME)-R$(PKG_VERSION).tgz
16 19
 PKG_SOURCE_URL:=http://www.mirbsd.org/MirOS/dist/mir/mksh
17
-PKG_MD5SUM:=71c7cbcd78306897801b8b6691091e66
20
+PKG_MD5SUM:=1c3882c07a760b23df1ad94ad0b4ed2e
18 21
 
19 22
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
20 23
 
@@ -36,7 +39,7 @@ derivate currently being actively developed.  It includes bug
36 39
 fixes and feature improvements, in order to produce a modern,
37 40
 robust shell good for interactive and especially script use.
38 41
 mksh has UTF-8 support (in substring operations and the Emacs
39
-editing mode) and - while R47 corresponds to OpenBSD 5.1-cur-
42
+editing mode) and - while R50 corresponds to OpenBSD 5.5-cur-
40 43
 rent ksh (without GNU bash-like PS1 and fancy character clas-
41 44
 ses) - adheres to SUSv4 and is much more robust. The code has
42 45
 been cleaned up and simplified, bugs fixed, standards compli-
@@ -50,13 +53,18 @@ define Build/Compile
50 53
 	# -DMKSH_ASSUME_UTF8=0 ⇒ never automatically enable
51 54
 	#	UTF-8 mode, neither use setlocale/nl_langinfo
52 55
 	#	nor look at $LC_* and $LANG (not recommended)
56
+	# -DMKSH_BINSHPOSIX ⇒ enable POSIX mode if called as sh
57
+	#XXX maybe change to -DMKSH_ASSUME_UTF8=1 now (which
58
+	#XXX is always assume UTF-8 mode)
53 59
 	# HAVE_CAN_FSTACKPROTECTORALL=0 ⇒ nuke libssp dependency
60
+	# HAVE_CAN_FSTACKPROTECTORSTRONG=0 ⇒ same, for gcc 4.9+
54 61
 	cd $(PKG_BUILD_DIR); \
55 62
 		CC="$(TARGET_CC)" \
56 63
 		TARGET_OS="$(shell uname -s)" \
57 64
 		CFLAGS="$(TARGET_CFLAGS)" \
58
-		CPPFLAGS="-DMKSH_SMALL=1 -DMKSH_ASSUME_UTF8=0" \
65
+		CPPFLAGS="-DMKSH_SMALL=1 -DMKSH_ASSUME_UTF8=0 -DMKSH_BINSHPOSIX" \
59 66
 		HAVE_CAN_FSTACKPROTECTORALL=0 \
67
+		HAVE_CAN_FSTACKPROTECTORSTRONG=0 \
60 68
 		LDFLAGS="$(TARGET_LDFLAGS)" \
61 69
 			$(BASH) Build.sh -Q -r -c lto
62 70
 endef

+ 6
- 6
utils/mksh/patches/100-dot_mkshrc View File

@@ -1,5 +1,5 @@
1
-From 2bee59bb9e6b142a78c94f5e77a54e4e2366c1b8 Mon Sep 17 00:00:00 2001
2
-From: Thorsten Glaser <tg@freewrt.org>
1
+From 23712cea8e2a623fd952eb781df0011c501703d0 Mon Sep 17 00:00:00 2001
2
+From: Thorsten Glaser <tg@mirbsd.org>
3 3
 Date: Thu, 25 Jul 2013 22:07:33 +0200
4 4
 Subject: [PATCH] Make default mkshrc file suitable for OpenWrt environment:
5 5
 
@@ -13,7 +13,7 @@ Subject: [PATCH] Make default mkshrc file suitable for OpenWrt environment:
13 13
  1 file changed, 7 insertions(+), 3 deletions(-)
14 14
 
15 15
 diff --git a/dot.mkshrc b/dot.mkshrc
16
-index c10b8fd..3a389b2 100644
16
+index 233a10c..caf482c 100644
17 17
 --- a/dot.mkshrc
18 18
 +++ b/dot.mkshrc
19 19
 @@ -28,8 +28,8 @@ case $KSH_VERSION in
@@ -33,10 +33,10 @@ index c10b8fd..3a389b2 100644
33 33
  alias ll='l -l'
34 34
 -alias lo='l -alo'
35 35
 +alias lo='l -al'
36
- alias doch='fc -ln -1 | sudo mksh -s'
36
+ alias doch='sudo mksh -c "$(fc -ln -1)"'
37 37
  whence -p rot13 >/dev/null || alias rot13='tr \
38 38
      abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ \
39
-@@ -413,4 +413,8 @@ alias cls='print -n \\033c'
39
+@@ -402,4 +402,8 @@ alias cls='print -n \\033c'
40 40
  
41 41
  unset p
42 42
  
@@ -46,5 +46,5 @@ index c10b8fd..3a389b2 100644
46 46
 +
47 47
  : place customisations above this line
48 48
 -- 
49
-1.8.3.2
49
+2.1.1
50 50