|
@@ -1,6 +1,6 @@
|
1
|
1
|
#
|
2
|
2
|
# Copyright (C) 2007-2011 OpenWrt.org
|
3
|
|
-# Copyright (c) 2009-2013 Thorsten Glaser <tg@mirbsd.org>
|
|
3
|
+# Copyright (c) 2009-2014 Thorsten Glaser <tg@mirbsd.org>
|
4
|
4
|
#
|
5
|
5
|
# This is free software, licensed under the GNU General Public License v2.
|
6
|
6
|
# See /LICENSE for more information.
|
|
@@ -9,12 +9,15 @@
|
9
|
9
|
include $(TOPDIR)/rules.mk
|
10
|
10
|
|
11
|
11
|
PKG_NAME:=mksh
|
12
|
|
-PKG_VERSION:=47
|
|
12
|
+PKG_VERSION:=50d
|
13
|
13
|
PKG_RELEASE:=1
|
14
|
14
|
|
|
15
|
+PKG_MAINTAINER:=Thorsten Glaser <tg@mirbsd.org>
|
|
16
|
+PKG_LICENSE:=MirOS
|
|
17
|
+
|
15
|
18
|
PKG_SOURCE:=$(PKG_NAME)-R$(PKG_VERSION).tgz
|
16
|
19
|
PKG_SOURCE_URL:=http://www.mirbsd.org/MirOS/dist/mir/mksh
|
17
|
|
-PKG_MD5SUM:=71c7cbcd78306897801b8b6691091e66
|
|
20
|
+PKG_MD5SUM:=1c3882c07a760b23df1ad94ad0b4ed2e
|
18
|
21
|
|
19
|
22
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
|
20
|
23
|
|
|
@@ -36,7 +39,7 @@ derivate currently being actively developed. It includes bug
|
36
|
39
|
fixes and feature improvements, in order to produce a modern,
|
37
|
40
|
robust shell good for interactive and especially script use.
|
38
|
41
|
mksh has UTF-8 support (in substring operations and the Emacs
|
39
|
|
-editing mode) and - while R47 corresponds to OpenBSD 5.1-cur-
|
|
42
|
+editing mode) and - while R50 corresponds to OpenBSD 5.5-cur-
|
40
|
43
|
rent ksh (without GNU bash-like PS1 and fancy character clas-
|
41
|
44
|
ses) - adheres to SUSv4 and is much more robust. The code has
|
42
|
45
|
been cleaned up and simplified, bugs fixed, standards compli-
|
|
@@ -50,13 +53,18 @@ define Build/Compile
|
50
|
53
|
# -DMKSH_ASSUME_UTF8=0 ⇒ never automatically enable
|
51
|
54
|
# UTF-8 mode, neither use setlocale/nl_langinfo
|
52
|
55
|
# nor look at $LC_* and $LANG (not recommended)
|
|
56
|
+ # -DMKSH_BINSHPOSIX ⇒ enable POSIX mode if called as sh
|
|
57
|
+ #XXX maybe change to -DMKSH_ASSUME_UTF8=1 now (which
|
|
58
|
+ #XXX is always assume UTF-8 mode)
|
53
|
59
|
# HAVE_CAN_FSTACKPROTECTORALL=0 ⇒ nuke libssp dependency
|
|
60
|
+ # HAVE_CAN_FSTACKPROTECTORSTRONG=0 ⇒ same, for gcc 4.9+
|
54
|
61
|
cd $(PKG_BUILD_DIR); \
|
55
|
62
|
CC="$(TARGET_CC)" \
|
56
|
63
|
TARGET_OS="$(shell uname -s)" \
|
57
|
64
|
CFLAGS="$(TARGET_CFLAGS)" \
|
58
|
|
- CPPFLAGS="-DMKSH_SMALL=1 -DMKSH_ASSUME_UTF8=0" \
|
|
65
|
+ CPPFLAGS="-DMKSH_SMALL=1 -DMKSH_ASSUME_UTF8=0 -DMKSH_BINSHPOSIX" \
|
59
|
66
|
HAVE_CAN_FSTACKPROTECTORALL=0 \
|
|
67
|
+ HAVE_CAN_FSTACKPROTECTORSTRONG=0 \
|
60
|
68
|
LDFLAGS="$(TARGET_LDFLAGS)" \
|
61
|
69
|
$(BASH) Build.sh -Q -r -c lto
|
62
|
70
|
endef
|