|
@@ -0,0 +1,176 @@
|
|
1
|
+## Copyright (C) 2009-2011 OpenWrt.org
|
|
2
|
+#
|
|
3
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
4
|
+# See /LICENSE for more information.
|
|
5
|
+#
|
|
6
|
+
|
|
7
|
+include $(TOPDIR)/rules.mk
|
|
8
|
+
|
|
9
|
+PKG_NAME:=gst1-plugins-good
|
|
10
|
+PKG_VERSION:=1.0.7
|
|
11
|
+PKG_RELEASE:=1
|
|
12
|
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
|
13
|
+
|
|
14
|
+PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-good-$(PKG_VERSION)
|
|
15
|
+PKG_SOURCE:=gst-plugins-good-$(PKG_VERSION).tar.xz
|
|
16
|
+PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-good/
|
|
17
|
+PKG_MD5SUM:=e4b1c825475a9b478fe29e8e9f34516f
|
|
18
|
+
|
|
19
|
+PKG_BUILD_DEPENDS:= gstreamer1 gst1-plugins-base liboil
|
|
20
|
+
|
|
21
|
+PKG_FIXUP:=autoreconf
|
|
22
|
+PKG_INSTALL:=1
|
|
23
|
+
|
|
24
|
+include $(INCLUDE_DIR)/package.mk
|
|
25
|
+include $(INCLUDE_DIR)/nls.mk
|
|
26
|
+
|
|
27
|
+define Package/gstreamer1/Default
|
|
28
|
+ CATEGORY:=Multimedia
|
|
29
|
+ SECTION:=multimedia
|
|
30
|
+ TITLE:=GStreamer
|
|
31
|
+ URL:=http://gstreamer.freedesktop.org/
|
|
32
|
+endef
|
|
33
|
+
|
|
34
|
+define Package/gstreamer1/description/Default
|
|
35
|
+ GStreamer open source multimedia framework
|
|
36
|
+endef
|
|
37
|
+
|
|
38
|
+
|
|
39
|
+define Package/gst1-plugins-good
|
|
40
|
+$(call Package/gstreamer1/Default)
|
|
41
|
+ TITLE+= plugins collection (good)
|
|
42
|
+ DEPENDS+= $(GST_DEPENDS)
|
|
43
|
+endef
|
|
44
|
+
|
|
45
|
+define Package/gts-plugins-good/description
|
|
46
|
+$(call Package/gstreamer1/description/Default)
|
|
47
|
+ .
|
|
48
|
+ This meta package contains only dependencies to the other plugins from
|
|
49
|
+ the good plugins collection.
|
|
50
|
+endef
|
|
51
|
+
|
|
52
|
+
|
|
53
|
+GST_VERSION:=1.0
|
|
54
|
+
|
|
55
|
+CONFIGURE_ARGS += \
|
|
56
|
+ --disable-debug \
|
|
57
|
+ --disable-examples \
|
|
58
|
+ \
|
|
59
|
+ --disable-aalib \
|
|
60
|
+ --disable-alpha \
|
|
61
|
+ --disable-annodex \
|
|
62
|
+ --disable-apetag \
|
|
63
|
+ --disable-auparse \
|
|
64
|
+ --disable-avi \
|
|
65
|
+ --disable-bz2 \
|
|
66
|
+ --disable-cairo \
|
|
67
|
+ --disable-directsound \
|
|
68
|
+ --disable-dv1394 \
|
|
69
|
+ --disable-effectv \
|
|
70
|
+ --disable-esd \
|
|
71
|
+ --disable-flv \
|
|
72
|
+ --disable-flx \
|
|
73
|
+ --disable-gconf \
|
|
74
|
+ --disable-gconftool \
|
|
75
|
+ --disable-gdk_pixbuf \
|
|
76
|
+ --disable-goom \
|
|
77
|
+ --disable-goom2k1 \
|
|
78
|
+ --disable-gst_v4l2 \
|
|
79
|
+ --disable-hal \
|
|
80
|
+ --disable-jpeg \
|
|
81
|
+ --disable-law \
|
|
82
|
+ --disable-libcaca \
|
|
83
|
+ --disable-libdv \
|
|
84
|
+ --disable-libpng \
|
|
85
|
+ --disable-matroska \
|
|
86
|
+ --disable-monoscope \
|
|
87
|
+ --disable-osx_audio \
|
|
88
|
+ --disable-osx_video \
|
|
89
|
+ --disable-pulse \
|
|
90
|
+ --disable-qtdemux \
|
|
91
|
+ --disable-rtspmanager \
|
|
92
|
+ --disable-smpte \
|
|
93
|
+ --disable-shout2 \
|
|
94
|
+ --disable-speex \
|
|
95
|
+ --disable-sunaudio \
|
|
96
|
+ --disable-taglib \
|
|
97
|
+ --disable-videobox \
|
|
98
|
+ --disable-videocrop \
|
|
99
|
+ --disable-videofilter \
|
|
100
|
+ --disable-videomixer \
|
|
101
|
+ --disable-wavpack \
|
|
102
|
+ --disable-x \
|
|
103
|
+ --disable-xshm \
|
|
104
|
+ --disable-xvideo \
|
|
105
|
+ --disable-y4m \
|
|
106
|
+ --disable-zlib \
|
|
107
|
+ \
|
|
108
|
+ --without-libiconv-prefix \
|
|
109
|
+ --without-libintl-prefix \
|
|
110
|
+ --without-x \
|
|
111
|
+
|
|
112
|
+EXTRA_LDFLAGS+= \
|
|
113
|
+ -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
|
|
114
|
+
|
|
115
|
+
|
|
116
|
+define Package/gst1-plugins-good/install
|
|
117
|
+ /bin/true
|
|
118
|
+endef
|
|
119
|
+
|
|
120
|
+
|
|
121
|
+# 1: short name
|
|
122
|
+# 2: description
|
|
123
|
+# 3: dependencies on other gstreamer libraries (short name)
|
|
124
|
+# 4: dependencies on other gstreamer plugins (short name)
|
|
125
|
+# 5: dependencies on other packages
|
|
126
|
+define GstBuildPlugin
|
|
127
|
+
|
|
128
|
+ GST_DEPENDS += +gst1-mod-$(1)
|
|
129
|
+
|
|
130
|
+ define Package/gst1-mod-$(1)
|
|
131
|
+ $(call Package/gstreamer1/Default)
|
|
132
|
+ TITLE+= $(2) plugin (good)
|
|
133
|
+ DEPENDS+= +libgstreamer1 $$(foreach p,$(3),+libgst1$$(p)) $$(foreach p,$(4),+gst1-mod-$$(p)) $(5)
|
|
134
|
+ endef
|
|
135
|
+
|
|
136
|
+ define Package/gst1-mod-$(1)/description
|
|
137
|
+ $(call Package/gstreamer1/description/Default)
|
|
138
|
+ .
|
|
139
|
+ This package contains the GStreamer $(2) plugin.
|
|
140
|
+ endef
|
|
141
|
+
|
|
142
|
+ define Package/gst1-mod-$(1)/install
|
|
143
|
+ $(INSTALL_DIR) $$(1)/usr/lib/gstreamer-$(GST_VERSION)
|
|
144
|
+ ( cd $(PKG_INSTALL_DIR); $(CP) \
|
|
145
|
+ ./usr/lib/gstreamer-$(GST_VERSION)/libgst$(1).so* \
|
|
146
|
+ $$(1)/usr/lib/gstreamer-$(GST_VERSION)/ \
|
|
147
|
+ )
|
|
148
|
+ endef
|
|
149
|
+
|
|
150
|
+ $$(eval $$(call BuildPackage,gst1-mod-$(1)))
|
|
151
|
+endef
|
|
152
|
+
|
|
153
|
+$(eval $(call GstBuildPlugin,audiofx,audio effects,audio fft controller,,))
|
|
154
|
+$(eval $(call GstBuildPlugin,autodetect,format auto-detection,,,))
|
|
155
|
+$(eval $(call GstBuildPlugin,cutter,audio cutter,audio,,))
|
|
156
|
+$(eval $(call GstBuildPlugin,debug,debugging,,,))
|
|
157
|
+$(eval $(call GstBuildPlugin,equalizer,audio equalizer,audio controller,,))
|
|
158
|
+$(eval $(call GstBuildPlugin,flac,FLAC codec,audio pbutils tag,,+libflac))
|
|
159
|
+$(eval $(call GstBuildPlugin,id3demux,ID3v1/v2 demuxer,pbutils tag,,))
|
|
160
|
+$(eval $(call GstBuildPlugin,icydemux,icy demuxer,audio tag,,))
|
|
161
|
+$(eval $(call GstBuildPlugin,interleave,audio interleave,audio,,))
|
|
162
|
+$(eval $(call GstBuildPlugin,level,audio level,audio,,))
|
|
163
|
+$(eval $(call GstBuildPlugin,audioparsers,audioparsers,audio tag,,))
|
|
164
|
+$(eval $(call GstBuildPlugin,multifile,multiple files access,video,,))
|
|
165
|
+$(eval $(call GstBuildPlugin,multipart,multipart stream handling,,,))
|
|
166
|
+$(eval $(call GstBuildPlugin,ossaudio,OSS audio support,audio,,))
|
|
167
|
+$(eval $(call GstBuildPlugin,replaygain,volume normalization,pbutils,,))
|
|
168
|
+$(eval $(call GstBuildPlugin,rtp,RTP,audio rtp tag pbutils video,,))
|
|
169
|
+$(eval $(call GstBuildPlugin,rtsp,RTSP,rtp rtsp sdp,,))
|
|
170
|
+$(eval $(call GstBuildPlugin,souphttpsrc,soup input,audio tag,,+libsoup))
|
|
171
|
+$(eval $(call GstBuildPlugin,spectrum,spectrum data output,audio fft,,))
|
|
172
|
+$(eval $(call GstBuildPlugin,udp,UDP,net,,))
|
|
173
|
+$(eval $(call GstBuildPlugin,wavenc,Wav encoder,riff,,))
|
|
174
|
+$(eval $(call GstBuildPlugin,wavparse,Wav parser,audio riff tag,,))
|
|
175
|
+
|
|
176
|
+$(eval $(call BuildPackage,gst1-plugins-good))
|