|
@@ -1,62 +0,0 @@
|
1
|
|
-#
|
2
|
|
-# Copyright (C) 2014 OpenWrt.org
|
3
|
|
-#
|
4
|
|
-# This is free software, licensed under the GNU General Public License v2.
|
5
|
|
-# See /LICENSE for more information.
|
6
|
|
-# updated to work with latest source from abrasive
|
7
|
|
-#
|
8
|
|
-
|
9
|
|
-include $(TOPDIR)/rules.mk
|
10
|
|
-
|
11
|
|
-PKG_NAME:=libsoxr
|
12
|
|
-PKG_VERSION:=0.1.1
|
13
|
|
-PKG_RELEASE:=1
|
14
|
|
-
|
15
|
|
-PKG_SOURCE_PROTO:=git
|
16
|
|
-PKG_SOURCE_URL:=git://git.code.sf.net/p/soxr/code
|
17
|
|
-PKG_SOURCE_VERSION:=HEAD
|
18
|
|
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
19
|
|
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
20
|
|
-PKG_LICENSE:=LGPL-2.0
|
21
|
|
-
|
22
|
|
-PKG_FIXUP:=libtool
|
23
|
|
-PKG_REMOVE_FILES:=autogen.sh
|
24
|
|
-
|
25
|
|
-PKG_BUILD_PARALLEL:=1
|
26
|
|
-
|
27
|
|
-include $(INCLUDE_DIR)/package.mk
|
28
|
|
-
|
29
|
|
-define Build/Configure
|
30
|
|
- $(CP) ./files/* $(PKG_BUILD_DIR)/
|
31
|
|
- $(call Build/Configure/Default, )
|
32
|
|
-endef
|
33
|
|
-
|
34
|
|
-define Package/libsoxr
|
35
|
|
- SECTION:=libs
|
36
|
|
- CATEGORY:=Libraries
|
37
|
|
- TITLE:=The SoX Resampler library
|
38
|
|
- URL:=http://sourceforge.net/projects/soxr/
|
39
|
|
- MAINTAINER:=Mike Brady <mikebrady@eircom.net>
|
40
|
|
- DEPENDS:= +libpthread
|
41
|
|
-endef
|
42
|
|
-
|
43
|
|
-define Package/libsoxr/description
|
44
|
|
- The SoX Resampler library
|
45
|
|
- High quality, one-dimensional sample-rate conversion library
|
46
|
|
-endef
|
47
|
|
-
|
48
|
|
-
|
49
|
|
-define Build/InstallDev
|
50
|
|
- $(INSTALL_DIR) $(1)/usr/include
|
51
|
|
- $(CP) $(PKG_BUILD_DIR)/src/soxr.h $(1)/usr/include/
|
52
|
|
- $(INSTALL_DIR) $(1)/usr/lib
|
53
|
|
- $(CP) $(PKG_BUILD_DIR)/src/*.a $(1)/usr/lib/
|
54
|
|
-endef
|
55
|
|
-
|
56
|
|
-define Package/libsoxr/install
|
57
|
|
- $(INSTALL_DIR) $(1)/usr/lib
|
58
|
|
- $(CP) $(PKG_BUILD_DIR)/src/*.a $(1)/usr/lib/
|
59
|
|
-endef
|
60
|
|
-
|
61
|
|
-
|
62
|
|
-$(eval $(call BuildPackage,libsoxr))
|