Pārlūkot izejas kodu

screen: import 4.2.1 from packages

Signed-off-by: Etienne CHAMPETIER <etienne.champetier@free.fr>
Etienne CHAMPETIER 10 gadus atpakaļ
vecāks
revīzija
d6078ba4a0

+ 52
- 0
utils/screen/Makefile Parādīt failu

@@ -0,0 +1,52 @@
1
+#
2
+# Copyright (C) 2006-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=screen
11
+PKG_VERSION:=4.2.1
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=@GNU/screen
16
+PKG_MD5SUM:=419a0594e2b25039239af8b90eda7d92
17
+
18
+include $(INCLUDE_DIR)/package.mk
19
+
20
+define Package/screen
21
+  SECTION:=utils
22
+  CATEGORY:=Utilities
23
+  DEPENDS:=+libncurses
24
+  TITLE:=Full-screen terminal window manager
25
+  URL:=http://www.gnu.org/software/screen/
26
+endef
27
+
28
+define Package/screen/description
29
+	Screen is a full-screen window manager that multiplexes a physical
30
+	terminal between several processes, typically interactive shells.
31
+endef
32
+
33
+define Build/Configure
34
+	$(call Build/Configure/Default,\
35
+		--with-sys-screenrc=/etc/screenrc \
36
+	)
37
+	# XXX: memmove() works well with overlapped memory areas
38
+	echo "#define USEMEMMOVE 1" >>$(PKG_BUILD_DIR)/config.h
39
+endef
40
+
41
+define Package/screen/install
42
+	$(INSTALL_DIR) $(1)/usr/sbin
43
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/screen $(1)/usr/sbin/
44
+	$(INSTALL_DIR) $(1)/etc
45
+	$(INSTALL_DATA) ./files/etc/screenrc $(1)/etc/screenrc
46
+endef
47
+
48
+define Package/screen/conffiles
49
+/etc/screenrc
50
+endef
51
+
52
+$(eval $(call BuildPackage,screen))

+ 1
- 0
utils/screen/files/etc/screenrc Parādīt failu

@@ -0,0 +1 @@
1
+startup_message off

+ 64
- 0
utils/screen/patches/100-cross_compile_fix.patch Parādīt failu

@@ -0,0 +1,64 @@
1
+--- a/configure
2
++++ b/configure
3
+@@ -414,7 +414,7 @@ as_fn_error ()
4
+     $as_echo "$as_me:${as_lineno-$LINENO}: error: $2" >&$4
5
+   fi
6
+   $as_echo "$as_me: error: $2" >&2
7
+-  as_fn_exit $as_status
8
++  # as_fn_exit $as_status
9
+ } # as_fn_error
10
+ 
11
+ if expr a : '\(a\)' >/dev/null 2>&1 &&
12
+@@ -5941,8 +5941,6 @@ else
13
+ fi
14
+ rm -f core conftest.err conftest.$ac_objext \
15
+     conftest$ac_exeext conftest.$ac_ext
16
+-test -f /lib/libsec.a || test -f /usr/lib/libsec.a && LIBS="$LIBS -lsec"
17
+-test -f /lib/libshadow.a || test -f /usr/lib/libshadow.a && LIBS="$LIBS -lshadow"
18
+ oldlibs="$LIBS"
19
+ LIBS="$LIBS -lsun"
20
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking IRIX sun library..." >&5
21
+@@ -7023,7 +7021,7 @@ as_fn_error ()
22
+     $as_echo "$as_me:${as_lineno-$LINENO}: error: $2" >&$4
23
+   fi
24
+   $as_echo "$as_me: error: $2" >&2
25
+-  as_fn_exit $as_status
26
++  # as_fn_exit $as_status
27
+ } # as_fn_error
28
+ 
29
+ 
30
+--- a/pty.c
31
++++ b/pty.c
32
+@@ -39,9 +39,9 @@
33
+ #endif
34
+ 
35
+ /* for solaris 2.1, Unixware (SVR4.2) and possibly others */
36
+-#ifdef HAVE_STROPTS_H
37
+-# include <sys/stropts.h>
38
+-#endif
39
++//#ifdef HAVE_STROPTS_H
40
++//# include <sys/stropts.h>
41
++//#endif
42
+ 
43
+ #if defined(sun) && defined(LOCKPTY) && !defined(TIOCEXCL)
44
+ # include <sys/ttold.h>
45
+--- a/sched.h
46
++++ b/sched.h
47
+@@ -27,6 +27,11 @@
48
+  * $Id$ GNU
49
+  */
50
+ 
51
++#ifndef __SCHED_H
52
++#define __SCHED_H
53
++
54
++#include <sys/time.h>
55
++
56
+ struct event
57
+ {
58
+   struct event *next;
59
+@@ -46,3 +51,5 @@ struct event
60
+ #define EV_READ		1
61
+ #define EV_WRITE	2
62
+ #define EV_ALWAYS	3
63
++
64
++#endif

+ 11
- 0
utils/screen/patches/110-do_not_add_srcdir_to_include_path.patch Parādīt failu

@@ -0,0 +1,11 @@
1
+--- a/Makefile.in
2
++++ b/Makefile.in
3
+@@ -79,7 +79,7 @@ screen: $(OFILES)
4
+ 	$(CC) $(LDFLAGS) -o $@ $(OFILES) $(LIBS)
5
+ 
6
+ .c.o:
7
+-	$(CC) -c -I. -I$(srcdir) $(M_CFLAGS) $(CPPFLAGS) $(DEFS) \
8
++	$(CC) -c $(M_CFLAGS) $(CPPFLAGS) $(DEFS) \
9
+ 	    $(OPTIONS) $(CFLAGS) $<
10
+ 
11
+ install_bin: .version screen